This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 508470 - playing music takes too much CPU (gstreamer pulsesink inefficiencies)
playing music takes too much CPU (gstreamer pulsesink inefficiencies)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-good (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 514739 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-27 10:31 EDT by Miroslav Lichvar
Modified: 2010-06-28 09:20 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:20:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
PulseAudio message from LG LT20 (5.75 KB, text/plain)
2009-08-22 14:57 EDT, Luya Tshimbalanga
no flags Details

  None (edit)
Description Miroslav Lichvar 2009-06-27 10:31:42 EDT
Description of problem:
When playing music on an older machine, the music player and pulseaudio processes take together about 40% of CPU. I've tried rhythmbox, exaile and gst-launch, all seem to have the same problem.

Music players not using gstreamer work fine, the usage is about 10%. Also, when redirecting the output to alsasink (with pulseaudio plugin enabled) instead of pulsesink, the usage is a bit lower, but still not good.

I'd suspect there is a bad interaction with pulseaudio or an unnecessary resampling in the audio path.

Version-Release number of selected component (if applicable):
gstreamer-0.10.23-2.fc11

How reproducible:
Always

Steps to Reproduce:
1. gst-launch filesrc location=foo.flac \! flacdec \! pulsesink
2. watch CPU usage
  
Actual results:
40%

Expected results:
10%

Additional info:
Comment 1 Zdenek Kabelac 2009-06-30 06:06:30 EDT
I'm experiencing pretty high CPU usage on my C2D as well - currently I've reverted whole pulseaudio package back to version 0.9.15-14.fc11 as version in rawhide is not usable at all.

Anyway this fc11 version takes over 10% of my C2D - which nearly equals to the time needed for mpeg4 decompression for some smaller movies.

I remember times when audio playback of mp3 was not visible in top - so I'd like to see same perfomance again.

If it's not possible with PA than its usage should be made only optional for those who like to waste CPU power....
Comment 2 Zdenek Kabelac 2009-07-01 05:25:54 EDT
I would suggest to reassign this bug to pulseaudio component.
Comment 3 Zdenek Kabelac 2009-08-05 09:07:51 EDT
Seems to be now duplicate of #514739
Comment 4 Miroslav Lichvar 2009-08-05 09:29:40 EDT
This is slightly different, players not using gstreamer don't use that much CPU, so I'd suspect gstreamer's pulsesink.
Comment 5 Luya Tshimbalanga 2009-08-22 14:57:00 EDT
Created attachment 358322 [details]
PulseAudio message from LG LT20

I have similar on both desktop and notebook. Reverting to old version of PulseAudio fixes the issue on desktop but I found out sound module fom LG LT20 got bug that made volume-control erratic (stop working after suspend).
Comment 6 Bastien Nocera 2009-10-08 12:03:25 EDT
Passing on to Pulseaudio as per last comment.
Comment 7 Lennart Poettering 2009-10-14 18:13:39 EDT
*** Bug 514739 has been marked as a duplicate of this bug. ***
Comment 8 Bastien Nocera 2009-10-15 06:15:21 EDT
This is a problem with the pulsesink interaction with PulseAudio:
http://thread.gmane.org/gmane.comp.video.gstreamer.devel/27064
Comment 9 Adam Williamson 2009-10-20 15:13:49 EDT
From the upstream discussion it seems like it should be / is being addressed in gstreamer, so re-assigning back to the appropriate gstreamer package for now. If there's an upstream bug for this, perhaps we should close this as it's being handled upstream?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Adam Williamson 2009-10-20 15:15:43 EDT
bastien, you seem to be the one who actually works on gstreamer-plugins-good these days, but the default assignee is ajax...re-assigning to you, perhaps the default needs to be changed. Adam doesn't seem to have touched the package since August 2008.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Bug Zapper 2010-04-27 11:17:54 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2010-06-28 09:20:02 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.