Bug 50849 - building python 2.1.1 breaks with:
building python 2.1.1 breaks with:
Status: CLOSED DUPLICATE of bug 19088
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-03 17:45 EDT by chris
Modified: 2016-11-24 09:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-03 17:45:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chris 2001-08-03 17:45:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010628

Description of problem:
when building python 2.1.1 it breaks with the error "LONG_BIT definition
appears wrong for platform (bad gcc/glibc config?)."
afaik I have the latest glibc gcc rpms for 7.0

How reproducible:
Always

Steps to Reproduce:
1.down load from python.org Python-2.1.1.tgz 
2.uncompress
3. ./configure
4. ./make
	

Actual Results:  make test
gcc -c -g -O2 -Wall -Wstrict-prototypes -I. -I./Include -DHAVE_CONFIG_H  -o
Modules/pyt
hon.o Modules/python.c
In file included from Include/Python.h:54,
                 from Modules/python.c:3:
Include/pyport.h:422:2: #error "LONG_BIT definition appears wrong for
platform (bad gcc
/glibc config?)."
make: *** [Modules/python.o] Error 1

Additional info:

other people have reported problems with 2.1 on RH7.0 on comp.lang.python
Comment 1 Jakub Jelinek 2001-08-07 09:00:54 EDT

*** This bug has been marked as a duplicate of 19088 ***

Note You need to log in before you can comment on or make changes to this bug.