Bug 508494 - Update to version 0.8.2
Update to version 0.8.2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-do (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
: 514263 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-27 17:48 EDT by David Kaylor
Modified: 2009-11-18 13:44 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 514263 (view as bug list)
Environment:
Last Closed: 2009-11-18 13:44:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec for gnome-do (6.77 KB, application/octet-stream)
2009-06-27 17:48 EDT, David Kaylor
no flags Details
Spec for gnome-do-plugins (2.34 KB, application/octet-stream)
2009-06-27 17:48 EDT, David Kaylor
no flags Details
Spec for gnome-do-docklets (2.06 KB, application/octet-stream)
2009-06-27 17:49 EDT, David Kaylor
no flags Details

  None (edit)
Description David Kaylor 2009-06-27 17:48:25 EDT
Created attachment 349673 [details]
Spec for gnome-do

Version 0.8.2 came out on 6/25/09. Attached are some spec files that I used to build this version for myself.  They work but may need some changes.  Note that there is a new docklets package and the Flicker plug-in doesn't build right on 64-bit systems.
Comment 1 David Kaylor 2009-06-27 17:48:56 EDT
Created attachment 349674 [details]
Spec for gnome-do-plugins
Comment 2 David Kaylor 2009-06-27 17:49:53 EDT
Created attachment 349675 [details]
Spec for gnome-do-docklets

I based this on the plugins spec.  Deps, etc are probably not accurate.
Comment 3 Lorenzo 2009-07-15 19:10:02 EDT
Thank you David, this specs works perfectly for me :)
Comment 4 Juan Manuel Rodriguez 2009-08-06 14:06:01 EDT
Any news? I need gnome-do 0.8.2 to update the plugins.
Comment 5 Juan Manuel Rodriguez 2009-08-07 12:06:29 EDT
*** Bug 514263 has been marked as a duplicate of this bug. ***
Comment 6 Lorenzo 2009-08-19 20:32:04 EDT
I've created gnome-do rpms using David specs...

If you want to download them, follow this link to my blog.
http://lordgiotto.wordpress.com/2009/08/17/gnome-do-0-8-2-per-fedora-11/

Hoping can be useful to someone :)
Comment 7 Michel Alexandre Salim 2009-08-19 20:39:45 EDT
David, are you a current Fedora packager? The primary maintainer, Sindre, appears to be busy -- so if you regularly use gnome-do, you might want to apply for commit access in the package database:

https://admin.fedoraproject.org/pkgdb/packages/name/gnome-do

Meanwhile, I'll take a look at the updated specs and commit them a.s.a.p. Thanks!
Comment 8 Juan Manuel Rodriguez 2009-08-19 20:50:51 EDT
If David's not interested, I am, as I maintain the gnome-do-plugins, and have been trying to get commit access for these packages for a while. 

I even created the Nonresponsive Maintainer bug here: 
https://bugzilla.redhat.com/show_bug.cgi?id=516797

Hope this gets cleared up soon.
Comment 9 Michel Alexandre Salim 2009-08-19 21:01:56 EDT
I've approved your ACL requests -- if you're taking over from Sindre completely, you might want to request ACLs for Fedora 10 as well, since it's still supported.

Would you like to do this update, or shall I? Computer's currently busy downloading the latest Rawhide soup, so if I don't get it done within the next few hours, feel free.
Comment 10 Juan Manuel Rodriguez 2009-08-19 21:05:03 EDT
Thanks Michael! I saw the commit emails. 

Add me for Fedora 10, I didn't request it initially, but if I'll maintain the package, I'll maintain in all of them. 

Should I close the Nonresponsive Maintainer bug?
Comment 11 Michel Alexandre Salim 2009-08-19 21:12:23 EDT
Not sure what to do with the other bug. Assuming Sindre is returning at some point, it's not urgent to pursue that track, since now you have sufficient privilege to perform all maintenance task.

Would you like to create a review request for gnome-do-docklets? It'd make sense for anyone with commit access to a gnome-do package to have access to the other packages too, that way updates can be pushed out in a coherent way.
Comment 12 Juan Manuel Rodriguez 2009-08-19 21:19:21 EDT
Yeah, I agree that the other bug's not urgent. 

Docklets, now there's something I hadn't heard of for gnome-do, but sure, I'll check it out and make an rpm. 

As for commit access for the gnome-do-plugins? Please do, I asked Sindre since the day I got the -plugins package and if you comaintain gnome-do, it makes sense to maintain -plugins too. 

Thanks.
Comment 13 David Kaylor 2009-08-19 21:39:31 EDT
I am a packager but it looks like Juan will get things back on track.  We'll definitely want the docklets for a full-featured 0.8.2 release.  If you need any help or would like me to review the docklets package since it is new, let me know.
Comment 14 Lorenzo 2009-08-24 11:02:44 EDT
Please, update Gnome-do also for Fedora 11 :)
Comment 15 Juan Manuel Rodriguez 2009-08-24 11:11:26 EDT
Lorenzo: 

We're working on it, and as soon as its ready, it'll be on Fedora 11. 

We're in the middle of a mass ppc64 rebuild on Fedora 11, which is why we haven't been able to update it.
Comment 16 Lorenzo 2009-08-24 13:25:04 EDT
Thank you very much :)
Comment 17 Juan Manuel Rodriguez 2009-11-18 13:44:09 EST
Closing bug, as 0.8.2 has been in Fedora for some time.

Note You need to log in before you can comment on or make changes to this bug.