Bug 508497 - Numeric keypad does not work in evince for data entry nor navigation modes.
Numeric keypad does not work in evince for data entry nor navigation modes.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evince (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Jonathan Blandford
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-27 18:27 EDT by Mike A. Harris
Modified: 2013-04-02 00:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-06 10:47:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2009-06-27 18:27:53 EDT
Description of problem:
The numeric keypad does not appear to work in evince on EL5, so numeric data
entry must be performed with the top row number keys instead.

Version-Release number of selected component (if applicable):
evince-0.6.0-8.el5.i386

How reproducible:
100%

Steps to Reproduce:
1. Load a multi-page PDF document into the evince viewer.
2. Click inside the page number entry field to the right of the left/right navigation arrows.
3. Make sure your "numlock" key is turned on by checking the keyboard LEDs
4. Try to type in a page number by using the numbers on the numeric keypad.

Actual results:
evince does not recognize the numerical keys on the numeric keypad, so number entry does not occur.  You need to use the top row number keys on the main part of the keyboard instead.

Expected results:
The numeric keypad should work, allowing the user to do numerical entry if the numlock mode is enabled.

Additional info:
The cursor navigation mode of the keypad does not work either (when numlock key is toggled and LED off).  Both the number-entry mode and navigation modes of the number pad should work for best customer experience.  Most likely the keys just are not bound.

Note - I've tested both number entry and navigation modes of the numeric keypad on various other GNOME, KDE apps, and at the commandline, etc. and it does work so this is just a bug or limitation in evince and I have confirmed it is not a buggy keyboard.

Hope this helps.
Comment 2 Mike A. Harris 2010-10-23 16:38:18 EDT
I'm unable to reproduce this problem with the current version of evince:

evince-0.6.0-13.el5.i386

Both numeric input and cursor navigation work with the numeric keypad now, so
closing bug as resolved in current release.
Comment 3 Mike A. Harris 2010-10-23 16:44:23 EDT
I closed this as CURRENTRELEASE, and for whatever reason bugzilla is showing the status as NOTABUG, and keeping it on my frontpage.cgi bug list.
Comment 4 Mike A. Harris 2010-10-23 16:45:30 EDT
Tried to set it to ERRATA this time and it still remains on NOTABUG.  Someone else can try to close it, must be a bug in bugzilla.

Note You need to log in before you can comment on or make changes to this bug.