Bug 508508 - No sound input from microphone [NEEDINFO]
No sound input from microphone
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-plugins (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AlsaVolume
  Show dependency treegraph
 
Reported: 2009-06-27 23:02 EDT by amturnip
Modified: 2010-06-28 09:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:20:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lpoetter: needinfo? (amturnip)


Attachments (Terms of Use)
pacmd list-sources (3.19 KB, text/plain)
2009-06-27 23:03 EDT, amturnip
no flags Details
alsa-info_A.txt (28.26 KB, text/plain)
2009-07-04 14:49 EDT, amturnip
no flags Details
amixer_A.txt (4.42 KB, text/plain)
2009-07-04 14:49 EDT, amturnip
no flags Details
alsa-info_B.txt (24.88 KB, text/plain)
2009-07-04 14:50 EDT, amturnip
no flags Details
amixer_B.txt (3.14 KB, text/plain)
2009-07-04 14:50 EDT, amturnip
no flags Details
alsa-info_C.txt (24.88 KB, text/plain)
2009-07-04 14:51 EDT, amturnip
no flags Details
amixer_C.txt (3.14 KB, text/plain)
2009-07-04 14:51 EDT, amturnip
no flags Details

  None (edit)
Description amturnip 2009-06-27 23:02:37 EDT
Gnome Sound Recorder records silence or inaudible noise.  Sound Preferences' Input panel reports an undetectable input level.  

In Sound Preferences, if I crank up "Input Volume" past 100%, Input level rises and Sound Recorder records louder white noise.


Steps to Reproduce:

0. plug microphone into jack in side of computer and position headset on head. Check and disable headset's mute.
1. open Sound Recorder.
2. press Record.
3. say stuff.
4. press Stop.
5. press Save.
6. save as an Ogg file.
7. play back with ogg123 filename.
8. in Sound Preferences, raise input volume to top of scale (beyond 100).
9. repeat steps 2-7 inclusive.
a. in Sound Preferences, put input volume back at 100.
  
Actual results:

For the first recording: Sound Recorder indicates low, steady volume level while recording. Listening to what ogg123 plays, I hear nothing. 
For the second recording: Sound Recorder indicates moderate, almost steady volume level. Listening to what ogg123 plays, I hear only static. 

Expected results:

Sound Recorder should record what I say.

Additional info:

$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1

$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

$ pacmd list-sources
(see attachment)

$ uname -a
Linux localhost.localdomain 2.6.29.5-191.fc11.x86_64 #1 SMP Tue Jun 16 23:23:21 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 amturnip 2009-06-27 23:03:36 EDT
Created attachment 349684 [details]
pacmd list-sources
Comment 2 amturnip 2009-06-28 10:08:48 EDT
There is another thing called Advanced Volume Control that has a control to "Toggle audio recording from Mic Mixer."  I pressed that toggle and Sound Recorder started capturing from the microphone.  

Therefore I have recategorized this report under "pulseaudio" in accordance with the instructions on "https://fedoraproject.org/wiki/Common_F11_bugs", which requests that a report be filed when it is necessary to install gst-mixer and use Advanced Volume Control to work around the Sound Preferences and ordinary volume control.
Comment 3 Lennart Poettering 2009-06-29 10:18:53 EDT
Could you please follow the instructions on:

https://bugzilla.redhat.com/show_bug.cgi?id=497966#c1

And get us that amixer output diff? This will then allow us to make this issue go away for future installations.

Please also include alsa-input.sh --no-upload output here.
Comment 4 amturnip 2009-06-30 19:41:12 EDT
I ran "alsactl init" but it did not cause the problem anew.  I noticed that it reduced the playback volume, but it did not re-mute the Mic Mixer.

By the way, "alsactl init" made this remark:

Unknown hardware: "HDA-Intel" "Intel G45 DEVCTG" "HDA:111d7675,102802be,00100103 HDA:80862802,80860101,00100000" "0x1028" "0x02be"
Hardware is initialized using a guess method
Comment 5 Lennart Poettering 2009-07-01 12:43:01 EDT
Could you please get the amixer before/after output then?
Comment 6 amturnip 2009-07-04 14:49:19 EDT
Created attachment 350504 [details]
alsa-info_A.txt
Comment 7 amturnip 2009-07-04 14:49:57 EDT
Created attachment 350505 [details]
amixer_A.txt
Comment 8 amturnip 2009-07-04 14:50:24 EDT
Created attachment 350506 [details]
alsa-info_B.txt
Comment 9 amturnip 2009-07-04 14:50:45 EDT
Created attachment 350507 [details]
amixer_B.txt
Comment 10 amturnip 2009-07-04 14:51:06 EDT
Created attachment 350508 [details]
alsa-info_C.txt
Comment 11 amturnip 2009-07-04 14:51:27 EDT
Created attachment 350509 [details]
amixer_C.txt
Comment 12 amturnip 2009-07-04 14:56:08 EDT
As indicated above, I could not reproduce the problem on the already-installed Fedora using alsactl init, so I reinstalled Fedora 11 from the DVD.

I took readings from alsa-info.sh and amixer. Those are the "A" attachments.

I thrashed around in Sound Preferences, Advanced Volume Control, and modprobe.conf to make the microphone work.

I took readings from alsa-info.sh and amixer. Those are the "B" attachments.

I ran "alsactl init" in an attempt to re-create the problem.  But, the microphone did not stop working.

I took readings from alsa-info.sh and amixer. Those are the "C" attachments.
Comment 13 Lennart Poettering 2009-07-23 09:07:15 EDT
Uh, A and B are from different sound cards!?
Comment 14 amturnip 2009-07-26 10:13:28 EDT
To the best of my understanding, there is only one sound card in the computer.  alsa-info_A.txt, alsa-info_B.txt, and alsa-info_C.txt all say this:


!!Soundcards recognised by ALSA
!!-----------------------------

 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfc700000 irq 22


!!PCI Soundcards installed in the system
!!--------------------------------------

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
Comment 15 Lennart Poettering 2009-07-27 10:11:06 EDT
Yes, but fact is that A and B are from different cards!
Comment 16 Bug Zapper 2010-04-27 11:18:42 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Bug Zapper 2010-06-28 09:20:42 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.