Bug 508509 - eapol and association race condition
eapol and association race condition
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-27 23:37 EDT by Jason Haar
Modified: 2009-12-22 14:57 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.6.8-6.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-22 14:57:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslogs (22.92 KB, application/octet-stream)
2009-11-20 00:03 EST, Jason Haar
no flags Details
backport of 0.7.x branch 1ff733383f3d5c73233ef452a738765667021609 (3.57 KB, patch)
2009-11-20 18:18 EST, Dan Williams
no flags Details | Diff

  None (edit)
Description Jason Haar 2009-06-27 23:37:28 EDT
Description of problem:

when I unsuspend my laptop, Fedora obviously reactivates all the hardware bits - including existing wireless connections. When it re-detects the wireless AP, instead of automatically reconnecting, it prompts me to confirm the network login details. All I have to do is hit "OK" (sorry, it may be a different string - it's not in front of me at the moment) and it re-connects successfully.


Version-Release number of selected component (if applicable):

Actually NetworkManager-gnome-0.7.1-4.git20090414.fc11.i586.rpm

How reproducible:

every time


Steps to Reproduce:
1. suspend
2. unsuspend
3. network popup appears telling it the network is down. Then it starts "swirling" and instead of reconnecting, it prompts me. I just hit RETURN and it works.

  
Actual results:


Expected results:


Additional info:

this is really a feature request - I don't really think it's classed as a bug :-)

but I do find it annoying and unnecessary. After all, it works without me having to do anything beyond hitting RETURN - so I'd argue from a usability perspective it shouldn't have bothered asking?
Comment 1 Stefan Becker 2009-07-07 16:06:40 EDT
I can confirm this, but with my Lenovo Thinkpad T60 it appears to be random (50-50?), i.e. sometimes it connects automatically after resume, sometimes the connect attempt fails and the prompt appears. This behaviour is not new with F11, I have seen it also previously.

I have seen this happening with WPA-EPA (multiple APs at work) and WPA-PSK (one AP at home).

Some of the failed attempts look like a timeout, i.e. I see the WLAN LED blinking (i.e. there *is* already encrypted communication) but the DHCP exchange (IP, route & DNS server) does not complete in time before NM gives up on the connection. Maybe it might be wise idea to bump the timeout a little bit higher after a resume?
Comment 2 Dan Williams 2009-11-19 19:14:03 EST
Can I get /var/log/messages from somebody's machine after you see this?  Based on that we may want to enable supplicant debugging and figure out what's going on further down the chain.
Comment 3 Jason Haar 2009-11-20 00:02:32 EST
Find attached

BTW I cam no longer running FC11 but am now running FC12 and still see the same problem

Jason
Comment 4 Jason Haar 2009-11-20 00:03:01 EST
Created attachment 372410 [details]
syslogs
Comment 5 Dan Williams 2009-11-20 17:35:49 EST
Seems to be an upstream issue in the supplicant.  Fix is:

http://w1.fi/gitweb/gitweb.cgi?p=hostap.git;a=commitdiff;h=1ff733383f3d5c73233ef452a738765667021609
Comment 6 Dan Williams 2009-11-20 18:18:16 EST
Created attachment 372633 [details]
backport of 0.7.x branch 1ff733383f3d5c73233ef452a738765667021609
Comment 7 Fedora Update System 2009-11-29 17:41:26 EST
wpa_supplicant-0.6.8-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/wpa_supplicant-0.6.8-6.fc11
Comment 8 Fedora Update System 2009-11-29 18:52:01 EST
wpa_supplicant-0.6.8-7.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/wpa_supplicant-0.6.8-7.fc12
Comment 9 Fedora Update System 2009-11-30 23:20:20 EST
wpa_supplicant-0.6.8-6.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wpa_supplicant'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-12346
Comment 10 Fedora Update System 2009-12-22 14:56:16 EST
wpa_supplicant-0.6.8-7.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-12-22 14:57:15 EST
wpa_supplicant-0.6.8-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.