Bug 508517 - The new package breaks update
The new package breaks update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: synce-hal (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-28 04:40 EDT by Andy Shevchenko
Modified: 2009-08-15 17:43 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.14-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-15 17:43:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Shevchenko 2009-06-28 04:40:52 EDT
Description of problem:
I have updated system from F-9 to F-10. After new synce-hal package is introduced the update became to be broken.

Version-Release number of selected component (if applicable):
Last official update for F-10

How reproducible:
[root@dhcppc74 ~]# yum update
Loaded plugins: fedorakmod, kernel-module, keys, refresh-packagekit, upgrade-helper, versionlock
Reading version lock configuration
Setting up Update Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package synce-hal.i386 0:0.13.1-3.fc10 set to be updated
--> Processing Dependency: libgnet-2.0.so.0 for package: synce-hal-0.13.1-3.fc10.i386
--> Processing Dependency: synce-serial for package: vdccm-0.10.1-3.fc9.i386
--> Processing Dependency: synce-serial for package: synce-kde-0.9.1-3.fc9.i386
--> Running transaction check
---> Package gnet2.i386 0:2.0.8-1.fc10 set to be updated
--> Processing Dependency: synce-serial for package: vdccm-0.10.1-3.fc9.i386
--> Processing Dependency: synce-serial for package: synce-kde-0.9.1-3.fc9.i386
--> Finished Dependency Resolution
vdccm-0.10.1-3.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: synce-serial is needed by package vdccm-0.10.1-3.fc9.i386 (installed)
synce-kde-0.9.1-3.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: synce-serial is needed by package synce-kde-0.9.1-3.fc9.i386 (installed)
Error: Missing Dependency: synce-serial is needed by package vdccm-0.10.1-3.fc9.i386 (installed)
Error: Missing Dependency: synce-serial is needed by package synce-kde-0.9.1-3.fc9.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dario Castellarin 2009-06-28 12:09:22 EDT
This also happens when trying to install the new synce-hal package from a previous installation of F10.
For compatibility reasons, I suggest a Provides:synce-serial.
Comment 2 Suhan Andrei 2009-06-29 15:40:06 EDT
Note : 

Security fixes and enhancement package updates can be installed separately. 

Hope this helps.
Comment 3 Suhan Andrei 2009-06-29 17:18:04 EDT
Workaround for updating other packages is to use yumex add all updates then remove from package queue "synce-hal"

Hope this helps.

PS: It looks like a careless mistake ! I wonder if someone tests package updates before pushing to large public and trashing Fedora experience. Users have other things to do than to check package dependencies and finding solutions for updating their systems don't you find this reasonable enough?
Comment 4 Rex Dieter 2009-07-07 10:39:07 EDT
triaged, confirmed (on F-11 too).

For example, see all the negative feedback/karma,
https://admin.fedoraproject.org/updates/F11/FEDORA-2009-6646
Comment 5 Suhan Andrei 2009-07-07 10:51:43 EDT
Even with so excellent negative feedback it gets into the repos and  
it keeps staying there for over a week. 

I think FEDORA has a hole into the process of publishing packages that needs to be closed ASAP.

In current state this package MUST HAVE ZERO open doors to any possible way that takes it to repository. 

Hope this helps.
Comment 6 Suhan Andrei 2009-07-07 13:04:53 EDT
It fails its own purpose : to be installed. 
This is so basic that FEDORA shall not grant them access into the update REPO. Shall stay only in update-testing and not pollute other good updates .
Comment 7 Suhan Andrei 2009-07-09 17:08:23 EDT
For Fedora QA:

Here is the QA Process described: http://fedoraproject.org/wiki/PackageSubmissionQAPolicy ?  What is the QACheck List that this package passed ?

Hope this helps to improve QA process.
Comment 8 Fedora Update System 2009-07-09 17:58:35 EDT
synce-hal-0.13.1-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/synce-hal-0.13.1-4.fc10
Comment 9 Michael Schwendt 2009-07-10 13:33:59 EDT
> triaged, confirmed (on F-11 too).

See my comment in bodhi.

The synce-hal that obsoletes synce-serial was added to Fedora 11 release in February already. Fedora 11 ships with synce-serial (which is used to satisfy the deps) *and* synce-hal, but synce-hal doesn't get installed.

The new synce-hal doesn't change the Obsoletes, it only enforces replacement of synce-serial during a yum update. [My Extras repoclosure probably also needs a fix to detect this.]


> Even with so excellent negative feedback it gets into the repos and  
> it keeps staying there for over a week. 

The F10 test-update has not received any negative karma by anyone.

The F11 test-update didn't change the Obsoletes tag, and it has seen negative karma only _after_ it got added to stable.
Comment 10 Suhan Andrei 2009-07-10 13:52:46 EDT
>The F10 test-update has not received any negative karma by anyone.
As long as F10 update repo is broken , Negative karma is there regardles of somebody anouncements/asignement of the bad karma for F10. 

I would give it lot of negative karma and double negative karma to the process of repo publishing that alows broken packages get into the update-repo. 

Hope this helps.
Comment 11 Michael Schwendt 2009-07-10 14:19:33 EDT
> Hope this helps.

No, it doesn't. You misunderstand the situation. With "karma" I refer to the voting in the Fedora Updates System.

See https://admin.fedoraproject.org/updates/F10/FEDORA-2009-6634

That's the update for F10. Nobody has given feedback while it was in updates-testing. [Same for the F11 update, although F11 is a different case as explained before.]

Admittedly, the maintainer should have caught this issue.
The community could have contributed a bit of testing, however.


[As a side-note, I've fixed Extras repoclosure, so it finds these issues. It made a wrong assumption when it found an obsolete provider.]
Comment 12 Suhan Andrei 2009-07-10 14:59:17 EDT
Thank you. 
I hope there shall no basicaly broken pakages in the repos .
Comment 13 Fedora Update System 2009-07-16 03:04:51 EDT
synce-hal-0.13.1-4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update synce-hal'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-7599
Comment 14 Suhan Andrei 2009-07-29 19:35:24 EDT
Hi,
updates-testing is BROKEN. Please Give GIGA NEGATIVE KARMA! 

su -c 'yum --enablerepo=updates-testing install synce-hal'
yum --enablerepo=updates-testing update synce-hal
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package synce-hal.x86_64 0:0.13.1-3.fc10 set to be updated
--> Processing Dependency: synce-serial for package: synce-kde-0.9.1-3.fc9.x86_64
--> Processing Dependency: synce-serial for package: vdccm-0.10.1-3.fc9.x86_64
--> Finished Dependency Resolution
synce-kde-0.9.1-3.fc9.x86_64 from installed has depsolving problems
  --> Missing Dependency: synce-serial is needed by package synce-kde-0.9.1-3.fc9.x86_64 (installed)
vdccm-0.10.1-3.fc9.x86_64 from installed has depsolving problems
  --> Missing Dependency: synce-serial is needed by package vdccm-0.10.1-3.fc9.x86_64 (installed)
Error: Missing Dependency: synce-serial is needed by package synce-kde-0.9.1-3.fc9.x86_64 (installed)
Error: Missing Dependency: synce-serial is needed by package vdccm-0.10.1-3.fc9.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
Comment 15 Fedora Update System 2009-08-01 20:02:11 EDT
libsynce-0.14-1.fc10, librapi-0.14-1.fc10, librra-0.14-1.fc10, synce-sync-engine-0.14-1.fc10, unshield-0.6-1.fc10, synce-kpm-0.14-1.fc10, synce-hal-0.14-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libsynce librapi librra synce-sync-engine unshield synce-kpm synce-hal'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8215
Comment 16 Suhan Andrei 2009-08-02 18:09:36 EDT
Thanks, I will try. meanwhile another package breaks update 
===========================================
perl(argv) is needed by package swig-1.3.39-1.fc10.x86_64 (updates)
perl(it) is needed by package swig-1.3.39-1.fc10.x86_64 (updates)
perl(the) is needed by package swig-1.3.39-1.fc10.x86_64 (updates) : Success - empty transaction
===========================================

Mega "Positive" Karma to "Michael Schwendt" as he pretends to have secured the 
open hole to the repository admission, but somehow there are more cases for the "repoclosure" to be considered as the stubborn swig package broke the repository again by misleading the improved "repoclosure".  

> As a side-note, I've fixed Extras repoclosure, so it finds these issues. It
> made a wrong assumption when it found an obsolete provider.
Comment 17 Suhan Andrei 2009-08-02 18:14:24 EDT
It looks the new testing packages are installing ok:

su -c 'yum --enablerepo=updates-testing update libsynce librapi librra synce-sync-engine unshield synce-kpm synce-hal'                                                           
Password:                                                                                             
Loaded plugins: refresh-packagekit                                                                    
updates-testing                                                                | 3.4 kB     00:00     
updates-testing/primary_db                                                     | 674 kB     00:08     
Setting up Update Process                                                                             
Package(s) synce-sync-engine available, but not installed.                                            
Resolving Dependencies                                                                                
--> Running transaction check                                                                         
--> Processing Dependency: librapi = 0.11.1-1.fc10 for package: python-rapi-0.11.1-1.fc10.x86_64      
---> Package librapi.x86_64 0:0.14-1.fc10 set to be updated                                           
---> Package librra.x86_64 0:0.14-1.fc10 set to be updated                                            
---> Package libsynce.x86_64 0:0.14-1.fc10 set to be updated                                          
---> Package synce-hal.x86_64 0:0.14-1.fc10 set to be updated                                         
---> Package synce-kpm.noarch 0:0.14-1.fc10 set to be updated                                         
---> Package unshield.x86_64 0:0.6-1.fc10 set to be updated                                           
--> Running transaction check                                                                         
---> Package python-rapi.x86_64 0:0.14-1.fc10 set to be updated                                       
--> Finished Dependency Resolution                                                                    

Dependencies Resolved

======================================================================================================
 Package                 Arch               Version                 Repository                   Size 
======================================================================================================
Installing:                                                                                           
 synce-hal               x86_64             0.14-1.fc10             updates-testing              47 k 
     replacing  synce-serial.x86_64 0.11-2.fc9                                                        

Updating:
 librapi                 x86_64             0.14-1.fc10             updates-testing             105 k
 librra                  x86_64             0.14-1.fc10             updates-testing             111 k
 libsynce                x86_64             0.14-1.fc10             updates-testing              45 k
 synce-kpm               noarch             0.14-1.fc10             updates-testing             129 k
 unshield                x86_64             0.6-1.fc10              updates-testing              27 k
Updating for dependencies:                                                                           
 python-rapi             x86_64             0.14-1.fc10             updates-testing              50 k

Transaction Summary
======================================================================================================
Install      1 Package(s)                                                                             
Update       6 Package(s)                                                                             
Remove       0 Package(s)                                                                             

Total download size: 514 k
Is this ok [y/N]: y       
Downloading Packages:     
(1/7): librapi-0.14-1.fc10.x86_64.rpm                                          | 105 kB     00:01     
(2/7): librra-0.14-1.fc10.x86_64.rpm                                           | 111 kB     00:01     
(3/7): libsynce-0.14-1.fc10.x86_64.rpm                                         |  45 kB     00:00     
(4/7): python-rapi-0.14-1.fc10.x86_64.rpm                                      |  50 kB     00:00     
(5/7): synce-hal-0.14-1.fc10.x86_64.rpm                                        |  47 kB     00:00     
(6/7): synce-kpm-0.14-1.fc10.noarch.rpm                                        | 129 kB     00:01     
(7/7): unshield-0.6-1.fc10.x86_64.rpm                                          |  27 kB     00:00     
------------------------------------------------------------------------------------------------------
Total                                                                  59 kB/s | 514 kB     00:08     
Running rpm_check_debug                                                                               
Running Transaction Test                                                                              
Finished Transaction Test                                                                             
Transaction Test Succeeded                                                                            
Running Transaction                                                                                   
  Updating       : libsynce-0.14-1.fc10.x86_64                                                   1/15 
/sbin/ldconfig: /usr/lib64/libmodbc.so.0 is not a symbolic link                                       

  Updating       : librapi-0.14-1.fc10.x86_64                                                    2/15 
/sbin/ldconfig: /usr/lib64/libmodbc.so.0 is not a symbolic link

  Updating       : python-rapi-0.14-1.fc10.x86_64                                                3/15
  Installing     : synce-hal-0.14-1.fc10.x86_64                                                  4/15
  Updating       : librra-0.14-1.fc10.x86_64                                                     5/15
/sbin/ldconfig: /usr/lib64/libmodbc.so.0 is not a symbolic link

  Updating       : unshield-0.6-1.fc10.x86_64                                                    6/15
/sbin/ldconfig: /usr/lib64/libmodbc.so.0 is not a symbolic link

  Updating       : synce-kpm-0.14-1.fc10.noarch                                                  7/15
  Cleanup        : synce-kpm-0.11.2-0.1.svn3491.fc10.noarch                                      8/15
  Cleanup        : python-rapi-0.11.1-1.fc10.x86_64                                              9/15
  Cleanup        : unshield-0.5.1-1.fc10.x86_64                                                 10/15
  Cleanup        : librapi-0.11.1-1.fc10.x86_64                                                 11/15
  Erasing        : odccm-0.11.1-1.fc10.x86_64                                                   12/15
  Erasing        : synce-serial-0.11-2.fc9.x86_64                                               13/15
  Cleanup        : libsynce-0.11.1-1.fc10.x86_64                                                14/15
/sbin/ldconfig: /usr/lib64/libmodbc.so.0 is not a symbolic link

  Cleanup        : librra-0.11.1-1.fc9.x86_64                                                   15/15

Installed:
  synce-hal.x86_64 0:0.14-1.fc10

Updated:
  librapi.x86_64 0:0.14-1.fc10      librra.x86_64 0:0.14-1.fc10     libsynce.x86_64 0:0.14-1.fc10
  synce-kpm.noarch 0:0.14-1.fc10    unshield.x86_64 0:0.6-1.fc10

Dependency Updated:
  python-rapi.x86_64 0:0.14-1.fc10

Replaced:
  odccm.x86_64 0:0.11.1-1.fc10                    synce-serial.x86_64 0:0.11-2.fc9

Complete!
Comment 18 Michael Schwendt 2009-08-03 03:01:10 EDT
> as the stubborn swig package broke the
> repository again by misleading the improved "repoclosure".  

You are mistaken. It correctly reported these trivial to find broken deps to the package owner(s).

However, repoclosure and the modified Extras repoclosure are _not_ in the position to block any updates automatically. The script is not used as an automated check during the updates repo compose process. The script is only run remotely [by me] when there are new test updates.

See my public reply to fedora-test-list where I hope to clear up your misunderstandings about QA.
Comment 19 Fedora Update System 2009-08-15 17:43:00 EDT
libsynce-0.14-1.fc10, librapi-0.14-1.fc10, librra-0.14-1.fc10, synce-sync-engine-0.14-1.fc10, unshield-0.6-1.fc10, synce-kpm-0.14-1.fc10, synce-hal-0.14-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.