Bug 508522 - \epsfig fails with "invalid image dimensions"
Summary: \epsfig fails with "invalid image dimensions"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 512524 (view as bug list)
Depends On:
Blocks: F12Target 511492 511585 511604 511709 511711 511785 511794 512446
TreeView+ depends on / blocked
 
Reported: 2009-06-28 10:59 UTC by Enrico Scholz
Modified: 2018-04-11 06:49 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-20 20:31:57 UTC
Type: ---


Attachments (Terms of Use)
LaTeX file (104 bytes, text/plain)
2009-06-28 10:59 UTC, Enrico Scholz
no flags Details
included pdf image (7.15 KB, application/pdf)
2009-06-28 11:00 UTC, Enrico Scholz
no flags Details
pdf source; translate it by 'fig2dev -Lpdf cell-struct.fig cell-struct.pdf' (1.70 KB, text/plain)
2009-06-28 11:01 UTC, Enrico Scholz
no flags Details

Description Enrico Scholz 2009-06-28 10:59:36 UTC
Created attachment 349697 [details]
LaTeX file

Description of problem:

Translating attached files succeeds in F11 and previous, but fails in rawhide:

$ pdflatex foo.tex
...
! pdfTeX error (ext1): invalid image dimensions.
...
l.4 \epsfig{figure=cell-struct}


Version-Release number of selected component (if applicable):

texlive-2007-43.fc12.x86_64


How reproducible:

100%

Comment 1 Enrico Scholz 2009-06-28 11:00:53 UTC
Created attachment 349698 [details]
included pdf image

Comment 2 Enrico Scholz 2009-06-28 11:01:56 UTC
Created attachment 349699 [details]
pdf source; translate it by 'fig2dev -Lpdf cell-struct.fig cell-struct.pdf'

Comment 3 Mattias Ellert 2009-07-25 09:56:36 UTC
Since this regression causes FTBFS for a number of packages, it prevents the F12 mass rebuild to complete → added to F12Alpha (since the rebuild is scheduled to be completed before the alpha release)

Comment 4 Mattias Ellert 2009-07-26 03:39:29 UTC
*** Bug 512524 has been marked as a duplicate of this bug. ***

Comment 5 Jesse Keating 2009-07-29 22:25:46 UTC
Since this doesn't block critical path of installing, logging in, and updating this is not a Alpha blocker.  If it prevents a rebuild of a package that does need to be fixed for a critical path issue, this bug can be made a blocker of that bug.

Comment 6 Mattias Ellert 2009-07-30 12:06:41 UTC
All my packages that failed to build due to this bug before (2009-07-25) worked today (2009-07-30). Maybe the F12 auto rebuild somehow fixed the problem.

Comment 7 Horst H. von Brand 2009-07-31 20:50:37 UTC
texlive-2007-44.fc12.x86_64

Now the problem went away.

Comment 8 Jindrich Novy 2009-08-01 08:35:44 UTC
Ok, closing then. Suspecting ghostscript as the culprit of the failure. Please reopen if you see this again.

Comment 9 Mattias Ellert 2009-08-13 13:56:42 UTC
Hi!

Today I saw failed builds from the SPARC Koji server that were caused by this issue.

http://sparc.koji.fedoraproject.org/koji/getfile?taskID=249167&name=build.log

Comment 10 Bug Zapper 2010-03-15 12:40:53 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Jindrich Novy 2010-04-22 17:25:20 UTC
Tried it again with TeX Live 2010 on F13 and it is now fixed. (will be fixed as soon as TL2010 is in Fedora)


Note You need to log in before you can comment on or make changes to this bug.