Bug 508534 - yum takes a big amount of time to exit while downloading
yum takes a big amount of time to exit while downloading
Status: CLOSED DUPLICATE of bug 524456
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-28 09:05 EDT by Cosimo Cecchi
Modified: 2014-01-21 18:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-13 11:40:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cosimo Cecchi 2009-06-28 09:05:54 EDT
- I was doing a yum upgrade, on a slow connection, and wanted to kill yum to save some bandwidth for browsing
- hit Ctrl+C, a message pops up saying to press Ctrl+C again to kill yum
- no matter how hard I try to press Ctrl+C, yum isn't killed, but ^C is recognized and printed on screen
- after some time (about a minute) finally yum quits
- I expected it to quit immediately after the second time I pressed Ctrl+C



(9/91): eclipse-cdt-5.0.2-3.fc11.i586.rpm                                                                                             |  15 MB     10:56 ... 

 Current download cancelled, interrupt (ctrl-c) again within two seconds to exit.

^C^C^C^C^C^C^C^C^C^C^C^C^C^C^C^C^C^C^C^C^C^C^C

Exiting on user cancel
^C

Exiting on user cancel.
[cosimoc@pluto: ~]$
Comment 1 Mads Kiilerich 2009-09-01 15:11:43 EDT
If this wasn't Fedora 11 it would have looked like a duplicate of bug 519233.

FWIW: My experience is that ctrl-c always worked acceptable in Fedora 11.
Comment 2 seth vidal 2009-09-01 15:24:49 EDT
the delay in exiting, in the past has always been a dns lookup issue in python. We're waiting for a response we can't break out of b/c of how low of a level it is.
Comment 3 seth vidal 2009-10-13 11:40:48 EDT

*** This bug has been marked as a duplicate of bug 524456 ***

Note You need to log in before you can comment on or make changes to this bug.