Bug 508550 - preupgrade insists on using NetworkManager, but IP address is static!!
preupgrade insists on using NetworkManager, but IP address is static!!
Status: CLOSED DUPLICATE of bug 475027
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
11
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-28 10:22 EDT by Chris Rankin
Modified: 2014-01-21 18:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-28 16:01:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Rankin 2009-06-28 10:22:32 EDT
Description of problem:
I have successfully run preupgrade and am now trying to reboot to start the actual upgrade process. However, anaconda keeps trying to configure my network interface via NetworkManager. (/boot didn't have enough space to contain everything, but this was apparently not a problem so long as there was a wired network available. Which there is.)

NetworkManager doesn't have a hope in *^%%! hell of configuring this network interface because it's configured statically. I therefore need a way of turning NetworkManager *OFF* and setting the network configuration manually.

I have already tried adding "asknetwork", "ip=.... netmask=.... dns=.... gateway=...." to my boot command line, but NetworkManager ignored them all.

Ditto with adding these parameters to my ks.cfg file.

Version-Release number of selected component (if applicable):


How reproducible:
EVERY TIME!!!


Steps to Reproduce:
1. Run preupgrade
2. Boot into the following kernel in my grub.conf file
title Upgrade to Fedora 11 (Leonidas)
	kernel /upgrade/vmlinuz asknetwork preupgrade repo=hd::/var/cache/yum/preupgrade stage2=http://www.mirrorservice.org/sites/download.fedora.redhat.com/pub/fedora/linux/releases/11/Fedora/i386/os/images/install.img ks=hd:UUID=75ca9d18-375e-41d2-96da-4f79794e4ba7:/upgrade/ks.cfg
	initrd /upgrade/initrd.img
3. Watch as NetworkManager repeatedly, stupidly tries to configure a network that isn't running DHCP.

Actual results:
Fedora 11 does not install. My blood pressure sky-rockets.

Expected results:
Fedora 10 is upgraded to Fedora 11.


Additional info:
Whose dumb idea was it to create an automated tool without a manual override?
Comment 1 Chris Rankin 2009-06-28 16:01:21 EDT

*** This bug has been marked as a duplicate of bug 475027 ***

Note You need to log in before you can comment on or make changes to this bug.