Bug 508567 - Virtual Machine aborts abrupt when executing rdesktop localhost:5900 command
Virtual Machine aborts abrupt when executing rdesktop localhost:5900 command
Status: CLOSED DUPLICATE of bug 501131
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-28 12:32 EDT by Michael Gruys
Modified: 2009-07-03 07:14 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-03 07:14:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Gruys 2009-06-28 12:32:20 EDT
Description of problem:
A running virtual machine in then virt-manager aborts without any warning (or entry in the logfile virt-manager.log) when in a terminal the 'rdesktop localhost:5900' will be executed (as normal user)

Version-Release number of selected component (if applicable):
Virtual Machine Manager 0.7.0

How reproducible:
Always

Steps to Reproduce:
1.start virt-manager
2.run a random installed virtual machine (i.e. right click on machine and choose Run)
3.open a terminal window (i.e. gnome-terminal)
4 type the following command: rdesktop localhost:5900
  
Actual results:
The running virtual machine will be aborted without warning or saving it's data. Any data loss in the virtual machine will occur!

Expected results:
A window of the running virtual machine will be showed in rdesktop
At least a warning that something is wrong that it is not possible to connect to the virtual machine

Additional info:
Comment 1 Daniel Berrange 2009-06-29 05:14:18 EDT
THis will be a bug in the QEMU VNC server not correctly validating client data, and then crashing. Can you tell me what version of 'qemu' RPM you have installed. 

NB, QEMU does not implement rdesktop, it implements VNC. So if you want to see the graphical console use virt-manager's console window, or 'virt-viewer' or the generic 'vinagre' VNC client.
Comment 2 Michael Gruys 2009-06-29 05:21:53 EDT
yum info qemu

Name       : qemu
Arch       : i586
Epoch      : 2
Version    : 0.10.5
Release    : 3.fc11
Size       : 0.0 
Repo       : installed
From repo  : updates

qemu
QEMU PC emulator version 0.10.5 (qemu-kvm-0.10.5), Copyright (c) 2003-2008 Fabrice Bellard
Comment 3 Michael Gruys 2009-06-29 16:08:11 EDT
Thanks for reply sir Berrange.
Should i file this issue under qemu (=make a new bug report)?

Thx in advance
Comment 4 Daniel Berrange 2009-06-29 17:41:53 EDT
I've already re-assigned this existing bug to 'qemu' so no need todo anything more at this time :-)
Comment 5 Mark McLoughlin 2009-07-03 07:14:07 EDT
Okay, I can reproduce and it looks like a dup of #501131

Thanks for the report!

*** This bug has been marked as a duplicate of bug 501131 ***

Note You need to log in before you can comment on or make changes to this bug.