Bug 508570 - abrt package fails to update
abrt package fails to update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
: 512736 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-28 12:53 EDT by pgaltieri
Modified: 2015-02-01 17:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 04:58:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pgaltieri 2009-06-28 12:53:34 EDT
Description of problem:
When trying to install latest F11 updates the abrt package failed to update due to conflict

Version-Release number of selected component (if applicable):
Fedora 11 with latest updates

How reproducible:
Always

Steps to Reproduce:
1. yum -y update abrt
2.
3.
  
Actual results:
[root@peglaptop10 ~]# yum -y update abrt
Loaded plugins: downloadonly, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: mirror.steadfast.net
 * rpmfusion-free: lordmorgul.net
 * rpmfusion-free-updates: lordmorgul.net
 * rpmfusion-nonfree: lordmorgul.net
 * rpmfusion-nonfree-updates: lordmorgul.net
 * updates: kdeforge.unl.edu
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: abrt = 0.0.3-1.fc11 for package: abrt-applet-0.0.3-1.fc11.x86_64
--> Processing Dependency: abrt = 0.0.3-1.fc11 for package: abrt-gui-0.0.3-1.fc11.x86_64
--> Processing Dependency: abrt = 0.0.3-1.fc11 for package: abrt-plugin-kerneloopsreporter-0.0.3-1.fc11.x86_64
--> Processing Dependency: abrt = 0.0.3-1.fc11 for package: abrt-plugin-kerneloops-0.0.3-1.fc11.x86_64
---> Package abrt.x86_64 0:0.0.4-3.fc11 set to be updated
--> Running transaction check
---> Package abrt-addon-kerneloops.x86_64 0:0.0.4-3.fc11 set to be updated
---> Package abrt-applet.x86_64 0:0.0.4-3.fc11 set to be updated
---> Package abrt-gui.x86_64 0:0.0.4-3.fc11 set to be updated
---> Package abrt-plugin-kerneloopsreporter.x86_64 0:0.0.4-3.fc11 set to be updated
--> Processing Conflict: abrt-addon-kerneloops-0.0.4-3.fc11.x86_64 conflicts kerneloops
--> Finished Dependency Resolution
abrt-addon-kerneloops-0.0.4-3.fc11.x86_64 from updates has depsolving problems
  --> abrt-addon-kerneloops conflicts with kerneloops
Error: abrt-addon-kerneloops conflicts with kerneloops
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


Expected results:
That it should update the package

Additional info:
Comment 1 Jiri Moskovcak 2009-06-29 04:21:23 EDT
It's intended behaviour, ABRT should conflict with kerneloops, so you have to remove it first.
Comment 2 pgaltieri 2009-06-29 20:21:01 EDT
If it's supposed to be removed then why doesn't yum do it for me?  It's done it in the past for other packages.  I thought yum was supposed to be an update manager?
Comment 3 Jiri Moskovcak 2009-06-30 03:14:20 EDT
It's not suposed to be removed, it's supposed to conflict with kerneloops. I could obsolete the kerneloops with abrt and then it would update ok, but I don't want to, because some users prefer kerneloops.
Comment 4 pgaltieri 2009-06-30 17:40:38 EDT
At some point in time both were allowed:

[root@peglaptop10 ~]# rpm -qa | grep abrt
abrt-plugin-kerneloops-0.0.3-1.fc11.x86_64
abrt-gui-0.0.3-1.fc11.x86_64
abrt-0.0.3-1.fc11.x86_64
abrt-libs-0.0.4-3.fc11.x86_64
abrt-plugin-kerneloopsreporter-0.0.3-1.fc11.x86_64
abrt-applet-0.0.3-1.fc11.x86_64
You have new mail in /var/spool/mail/root
[root@peglaptop10 ~]# rpm -qa | grep kerneloops
abrt-plugin-kerneloops-0.0.3-1.fc11.x86_64
abrt-plugin-kerneloopsreporter-0.0.3-1.fc11.x86_64
kerneloops-0.12-5.fc11.x86_64

So you've changed abrt-plugin-kerneloops to conflict with kerneloops?
Comment 5 Jiri Moskovcak 2009-07-01 06:01:43 EDT
Yes, this is new in version 0.0.4 that's why it causing trouble with upgrade. Yum or PackageKit should offer some way how to solve these situations other than just fail.
Comment 6 Jiri Moskovcak 2009-07-20 12:12:33 EDT
*** Bug 512736 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.