Bug 508594 - (Kiboney) FGLRX freezes system on boot with ATI HD 4850 on Fedora 11
FGLRX freezes system on boot with ATI HD 4850 on Fedora 11
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-28 19:57 EDT by Kiboney
Modified: 2009-06-29 09:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 08:17:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log with FGLRX (13.51 KB, text/plain)
2009-06-28 19:57 EDT, Kiboney
no flags Details
Xorg.log with FGLRX (13.51 KB, text/plain)
2009-06-28 19:59 EDT, Kiboney
no flags Details
Dmesg with fglrx (41.90 KB, text/plain)
2009-06-28 20:02 EDT, Kiboney
no flags Details

  None (edit)
Description Kiboney 2009-06-28 19:57:30 EDT
Created attachment 349718 [details]
Xorg.log with FGLRX

Description of problem:

When I install FGLRX from the official ati website http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.36&lang=English , after reboot the whole system hangs on the fedora logo once it has completed - never goes to gdm. I could not reset the X server using ctrl+alt+backspace ( I did activate it on Fedora 11 ), and I could not use alt-f2, nothing.

I was able to to reboot into init 3, copy the log files, uninstall fglrx successfully and reboot back to the GUI without any crashes. After reproducing the problem several times, I played with xorg.conf and even told it not to load fglrx on startup, but no success. I tried installing the older, 9.5 version of the driver - screen turned black and halted on boot after the fedora logo.

Every time I boot back to the GUI, it reports me that the kernel has crashed. I copied the report somewhere, I will post it as soon as I find it.

I also found another person on the linuxquestions.org forums with the exact same problem - s/he also has HD 4850 and Fedora 11.

Kernel versions tested were 2.6.29.4 and 2.6.29.5, i586

I used to have Fedora 10, and the ati drivers from the official ati website worked perfectly.

After comparing the logs with fglrx and the logs without fglrx, I found some lines that may or may not be essential to solving this problem.

---

Xorg.0.log

Most notable lines with fglrx

...
(WW) Falling back to old probe method for fglrx
(II) ATI Proprietary Linux Driver Version Identifier:8.62.4
(II) ATI Proprietary Linux Driver Release Identifier: 8.62                                 
(II) ATI Proprietary Linux Driver Build Date: May 20 2009 16:45:27
(II) Loading PCS database from /etc/ati/amdpcsdb
(WW) This ATI Proprietary Linux Driver does not guarantee support of video driver ABI higher than 2.0
(WW) Video driver ABI version of the X server is 5.0
(--) Chipset Supported AMD Graphics Processor (0x9442) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
(II) AMD Video driver is running on a device belonging to a group targeted for this release
(II) AMD Video driver is signed
...
(==) fglrx(0): NoAccel = NO
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/lib/xorg/modules//libxaa.so
(II) Module xaa: vendor="X.Org Foundation"
	compiled for 1.6.1.901, module version = 1.2.1
	ABI class: X.Org Video Driver, version 5.0
(==) fglrx(0): NoDRI = NO
(==) fglrx(0): Capabilities: 0x00000000
(==) fglrx(0): CapabilitiesEx: 0x00000000
(==) fglrx(0): cpuFlags: 0x8000001d
(==) fglrx(0): OpenGL ClientDriverName: "fglrx_dri.so"
...

---

dmesg.log

...
uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
irq 22: nobody cared (try booting with the "irqpoll" option)
Pid: 1200, comm: ifup-ipv6 Not tainted 2.6.29.5-191.fc11.i586 #1
Call Trace:
 [<c04691d8>] __report_bad_irq+0x33/0x74
 [<c046930b>] note_interrupt+0xf2/0x14f
 [<c0468486>] ? handle_IRQ_event+0x61/0x69
 [<c0469895>] handle_fasteoi_irq+0x93/0xb9
 [<c0405a31>] do_IRQ+0x92/0xad
 [<c040452c>] common_interrupt+0x2c/0x40
handlers:
[<f8822666>] (azx_interrupt+0x0/0x109 [snd_hda_intel])
Disabling IRQ #22
firewire_core: created device fw0: GUID 001320000079331f, S800
...




Steps to Reproduce:
1. Install v. 9.5 - 9.6 of ati driver from official website;
   with HD 4850 and F11
2. Reboot.
3. Attempt to fix by uninstalling from init 3.
  
Actual results:

The Fedora logo fills up, parts of the screen flickers a bit, then it freezes with the filled up Fedora logo

Expected results:

Fedora logo fills and gdm shows up seconds later.

Additional info:

I am quite new to posting bug reports, debugging linux and linux itself, so I may not get the whole concept of this.
Comment 1 Kiboney 2009-06-28 19:59:54 EDT
Created attachment 349719 [details]
Xorg.log with FGLRX
Comment 2 Kiboney 2009-06-28 20:02:13 EDT
Created attachment 349720 [details]
Dmesg with fglrx
Comment 3 Matěj Cepl 2009-06-29 08:17:56 EDT
Thanks for the report. We are sorry that we cannot help you with your problem, but we are not able to support binary-only drivers. If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

If you need support for software provided by third parties, I think it would be better to ask them for help.
Comment 4 Kiboney 2009-06-29 09:58:20 EDT
Understood. Thanks.

Note You need to log in before you can comment on or make changes to this bug.