Bug 508610 - Content Overflow in Table Cells
Content Overflow in Table Cells
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Ruediger Landmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 01:14 EDT by David Le Sage
Modified: 2010-11-23 23:17 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.2-0.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-20 00:19:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XML sample of informal table. (796 bytes, text/xml)
2009-06-29 01:14 EDT, David Le Sage
no flags Details
Here is a screen capture of the bug taken in Fedora. You can see the overflow in the bottom line. (24.07 KB, image/png)
2009-06-29 01:22 EDT, David Le Sage
no flags Details
Here is a screen capture of the same portion of the file rendered correctly in Pubican 4.5 on RHEL. (26.29 KB, image/png)
2009-06-29 01:24 EDT, David Le Sage
no flags Details
From PDF rendered with BETA on Fedora 11 (36.40 KB, image/png)
2009-09-08 20:38 EDT, Ruediger Landmann
no flags Details

  None (edit)
Description David Le Sage 2009-06-29 01:14:49 EDT
Created attachment 349729 [details]
XML sample of informal table.

Description of problem:
Content is overflowing in BOTH ordered and itemized lists from one cell to the cell below.

Version-Release number of selected component (if applicable):
publican-redhat-0.19-0.fc11.noarch
publican-0.44-0.fc11.noarch
publican-fedora-0.18-0.t1.fc11.noarch
publican-0.40-0.fc9.noarch
publican-jboss-0.19-0.fc11.noarch


How reproducible:
Yes. Tested in both ordered and itemized lists.

Steps to Reproduce:
1. Take informal table from attached PDF file.
2. Paste it into a book.
3. Compile as PDF.
  
Actual results:
Table overflows. Refer to screenshots

Expected results:
Table should not overflow. Refer to screenshots.


Additional info:
Cannot test in later versions of Publican due to other PDF bugs.

Tested in 0.45 on RHEL and bug does not manifest in Publican.
Comment 1 David Le Sage 2009-06-29 01:22:42 EDT
Created attachment 349731 [details]
Here is a screen capture of the bug taken in Fedora.  You can see the overflow in the bottom line.

Here is a screen capture of the bug taken in Fedora.  You can see the overflow in the bottom line.


I have viewed the PDF in both Evince and Okular and it can be seen in both cases.
Comment 2 David Le Sage 2009-06-29 01:24:05 EDT
Created attachment 349732 [details]
Here is a screen capture of the same portion of the file rendered correctly in Pubican 4.5 on RHEL.

Here is a screen capture of the same portion of the file rendered correctly in Publican 0.45 on RHEL.
Comment 3 Ruediger Landmann 2009-06-30 01:57:13 EDT
Not a bug in the Fedora brand.
Comment 4 Jeff Fearn 2009-08-10 20:37:14 EDT
This should be fixed in the BETA.
Comment 5 Ruediger Landmann 2009-09-08 20:38:38 EDT
Created attachment 360150 [details]
From PDF rendered with BETA on Fedora 11
Comment 6 Ruediger Landmann 2009-09-08 20:39:28 EDT
Fixed in 1.0 

PDF built using sample code from above. Table renders correctly.
Comment 7 Fedora Update System 2009-11-17 21:18:15 EST
publican-1.2-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.2-0.fc12
Comment 8 Fedora Update System 2009-11-20 00:17:14 EST
publican-1.2-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2009-11-25 09:52:25 EST
publican-1.2-0.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.