Bug 508631 - use hunspell instead of aspell
use hunspell instead of aspell
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: squirrelmail (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 04:57 EDT by Caolan McNamara
Modified: 2009-06-30 06:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 06:28:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
point at hunspell instead of aspell (849 bytes, patch)
2009-06-29 04:57 EDT, Caolan McNamara
no flags Details | Diff

  None (edit)
Description Caolan McNamara 2009-06-29 04:57:54 EDT
Created attachment 349757 [details]
point at hunspell instead of aspell

Description of problem:
squirrelmail requires aspell. We've been trying to centralize on one set of dictionaries for some time now (http://fedoraproject.org/wiki/Releases/FeatureDictionary)

Version-Release number of selected component (if applicable):
squirrelmail-1.4.19

a) The requires is on aspell, looking at the default config it then advertises spellchecking in "English" and "Spanish". Attached is a patch to use hunspell instead of ispell/aspell which would need a corresponding change in Requires to hunspell instead of aspell

b) Either way, with this patch or not, squirrelmail should probably require: the specific dictionaries to fulfil the built-in pre-customization claim to be able to spellchecking english/spanish, e.g. hunspell-en and hunspell-es with patch, or aspell-en and aspell-es without patch
Comment 1 Michal Hlavinka 2009-06-30 06:28:15 EDT
(In reply to comment #0)
> Created an attachment (id=349757) [details]
> point at hunspell instead of aspell
> 
> Description of problem:
> squirrelmail requires aspell. We've been trying to centralize on one set of
> dictionaries for some time now
> (http://fedoraproject.org/wiki/Releases/FeatureDictionary)
> 
> a) The requires is on aspell, looking at the default config it then advertises
> spellchecking in "English" and "Spanish". Attached is a patch to use hunspell
> instead of ispell/aspell which would need a corresponding change in Requires to
> hunspell instead of aspell

done

> b) Either way, with this patch or not, squirrelmail should probably require:
> the specific dictionaries to fulfil the built-in pre-customization claim to be
> able to spellchecking english/spanish, e.g. hunspell-en and hunspell-es with
> patch, or aspell-en and aspell-es without patch  

hunspell-en added, I've removed ispell-es from config file completely

Note You need to log in before you can comment on or make changes to this bug.