Bug 508652 - eeepc sometimes doesn't suspend properly (suspend to ram)
eeepc sometimes doesn't suspend properly (suspend to ram)
Status: CLOSED DUPLICATE of bug 508106
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 06:48 EDT by Stefan Assmann
Modified: 2009-07-15 06:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-15 06:10:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Assmann 2009-06-29 06:48:27 EDT
Description of problem:
every few attempts to suspend my eeepc 1000he it does not suspend properly. When I push the s2ram button it will try to suspend but doesn't really do it properly only the screen goes black but the machine is still on power. When I push any key the screen will come back showing the boot messages but no further interaction with the machine is possible. Can't even change vts. I can still login from a remote machine and look at dmesg but everything I tried to get the screen working again failed.

chvt 2                    hangs
killall -9 gdm-binary     doesn't show any effect

Version-Release number of selected component (if applicable):
uname -a
Linux eeepc 2.6.29.4-167.fc11.i686.PAE

How reproducible:
sometimes

Steps to Reproduce:
1. push sleep button on eeepc
2.
3.
  
Actual results:
doesn't suspend properly

Expected results:
suspend properly

Additional info:
last few lines from dmesg:
PM: Finishing wakeup.
Restarting tasks ... done.
ATL1E 0000:03:00.0: irq 27 for MSI/MSI-X
ADDRCONF(NETDEV_UP): eth0: link is not ready
ADDRCONF(NETDEV_UP): wlan0: link is not ready
CPU0 attaching NULL sched-domain.
CPU1 attaching NULL sched-domain.
CPU0 attaching sched-domain:
 domain 0: span 0-1 level SIBLING
  groups: 0 1
CPU1 attaching sched-domain:
 domain 0: span 0-1 level SIBLING
  groups: 1 0
wlan0: direct probe to AP 00:1c:df:ce:a9:6a try 1
wlan0: direct probe to AP 00:1c:df:ce:a9:6a try 2
wlan0: direct probe to AP 00:1c:df:ce:a9:6a try 3
wlan0: direct probe to AP 00:1c:df:ce:a9:6a timed out
wlan0: authenticate with AP 00:22:15:6f:26:1d
wlan0: authenticated
wlan0: associate with AP 00:22:15:6f:26:1d
wlan0: RX AssocResp from 00:22:15:6f:26:1d (capab=0x431 status=0 aid=2)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
SELinux: initialized (dev 0:13, type nfs), uses genfs_contexts
wlan0: no IPv6 routers present
wlan0 direct probe responded
wlan0: authenticate with AP 00:22:15:6f:26:1d
wlan0: authenticated
wlan0: associate with AP 00:22:15:6f:26:1d
wlan0: RX ReassocResp from 00:22:15:6f:26:1d (capab=0x431 status=0 aid=2)
wlan0: associated
wlan0: disassociating by local choice (reason=3)
wlan0: direct probe to AP 00:22:15:6f:26:1d try 1
wlan0 direct probe responded
wlan0: authenticate with AP 00:22:15:6f:26:1d
wlan0: authenticated
wlan0: associate with AP 00:22:15:6f:26:1d
wlan0: RX AssocResp from 00:22:15:6f:26:1d (capab=0x431 status=0 aid=2)
wlan0: associated
ACPI: EC: missing confirmations, switch off interrupt mode.
ACPI Exception (evregion-0422): AE_TIME, Returned by Handler for [EmbeddedControl] [20081204]
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_.EBTS] (Node f70150f0), AE_TIME
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_.UBCS] (Node f7018f90), AE_TIME
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.CBST] (Node f7019120), AE_TIME
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.BAT0._BST] (Node f7019060), AE_TIME
ACPI Exception (battery-0382): AE_TIME, Evaluating _BST [20081204]

lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GME Express Memory Controller Hub [8086:27ac] (rev 03)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GME Express Integrated Graphics Controller [8086:27ae] (rev 03)
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 [8086:27d0] (rev 02)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 [8086:27d2] (rev 02)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 [8086:27d6] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 [8086:27c8] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 [8086:27c9] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 [8086:27ca] (rev 02)
00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 [8086:27cb] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller [8086:27cc] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 02)
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller [8086:27c4] (rev 02)
01:00.0 Network controller [0280]: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) [168c:002a] (rev 01)
03:00.0 Ethernet controller [0200]: Attansic Technology Corp. Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller [1969:1026] (rev b0)
Comment 1 Paul Lipps 2009-07-07 20:43:11 EDT
I have not encountered this issue on my ASUS Eee PC 1000HE. I have tested this
under both BIOSes 802 and 902. My kernel is 2.6.29.5-191.fc11.i586. The system
always recovers from suspend or hibernate as expected.

If there is any output I can provide to assist, please let me know.
Comment 2 Stefan Assmann 2009-07-15 06:10:20 EDT

*** This bug has been marked as a duplicate of bug 508106 ***

Note You need to log in before you can comment on or make changes to this bug.