Bug 508656 - S-c-tools cleanup: unable to start system-config-samba
S-c-tools cleanup: unable to start system-config-samba
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-samba (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 493610
  Show dependency treegraph
 
Reported: 2009-06-29 07:04 EDT by Roman Rakus
Modified: 2014-01-12 19:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-30 10:57:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roman Rakus 2009-06-29 07:04:05 EDT
Description of problem:
There is unhandled exception

How reproducible: 

Steps to Reproduce:
1.  just try to run system-config-samba
2. 
3. 

Actual results:
[rrakus@localhost ~]$ system-config-samba 
Traceback (most recent call last):
  File "/usr/bin/system-config-samba", line 49, in <module>
    mainWindow.MainWindow (debug_flag = debug_flag, use_dbus = use_dbus)
  File "/usr/share/system-config-samba/mainWindow.py", line 95, in __init__
    self.samba_backend = sambaBackend.SambaBackend (bus = self._bus)
  File "/usr/lib/python2.6/site-packages/scsamba/dbus/proxy/sambaBackend.py", line 31, in __init__
    self.dbus_object = bus.get_object (dbus_service_name, self.dbus_service_path)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 241, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 183, in activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 281, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1

Expected results:

Additional info:
This bug report is part of "System Configuration Tools Cleanup Project". Don't
hesitate to ask project maintainers for any kind of help.
Comment 1 Roman Rakus 2009-06-29 07:07:46 EDT
Another one:
[rrakus@localhost ~]$ system-config-samba 
Traceback (most recent call last):
  File "/usr/bin/system-config-samba", line 49, in <module>
    mainWindow.MainWindow (debug_flag = debug_flag, use_dbus = use_dbus)
  File "/usr/share/system-config-samba/mainWindow.py", line 104, in __init__
    self.samba_data = sambaConfig.SambaConfig (self.samba_backend)
  File "/usr/lib/python2.6/site-packages/scsamba/core/sambaConfig.py", line 29, in __init__
    self.parseFile ()
  File "/usr/lib/python2.6/site-packages/scsamba/core/sambaConfig.py", line 32, in parseFile
    return self.parse (self.backend.readSmbConf ())
  File "/usr/lib/python2.6/site-packages/slip/dbus/polkit.py", line 65, in enable_proxy_wrapper
    return func (*p, **k)
  File "/usr/lib/python2.6/site-packages/scsamba/dbus/proxy/sambaBackend.py", line 48, in readSmbConf
    return self.dbus_interface.readSmbConf ()
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.RuntimeError: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.6/site-packages/slip/dbus/service.py", line 81, in wrapped_method
    retval = method (self, *p, **k)
  File "/usr/lib/python2.6/site-packages/scsamba/dbus/service/sambaBackend.py", line 52, in readSmbConf
    return self.backend.readSmbConf ()
  File "/usr/lib/python2.6/site-packages/scsamba/core/sambaBackend.py", line 105, in readSmbConf
    self.readSmbPasswords ()
  File "/usr/lib/python2.6/site-packages/scsamba/core/sambaBackend.py", line 148, in readSmbPasswords
    raise RuntimeError, (_("Error while reading Samba password list:\n%s") % "\n".join (map (str.strip, list)))
RuntimeError: Error while reading Samba password list:
/usr/bin/pdbedit: symbol lookup error: /usr/bin/pdbedit: undefined symbol: _talloc_get_type_abort
Comment 2 Bug Zapper 2009-11-16 05:30:58 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Nils Philippsen 2009-12-30 10:57:36 EST
I can't reproduce these problems anymore, they seem to have been fixed with SELinux/samba updates.

Note You need to log in before you can comment on or make changes to this bug.