Bug 508665 - virt-manager (running as unprivileged user) doesn't let me install from NFS locations
virt-manager (running as unprivileged user) doesn't let me install from NFS l...
Status: CLOSED DUPLICATE of bug 501922
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-06-29 07:57 EDT by Nils Philippsen
Modified: 2009-09-22 09:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-22 09:55:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2009-06-29 07:57:16 EDT
Description of problem:
When attempting to install a VM from an NFS location, I get an error message about missing privileges after step 2 ("Provide the operating system URL").

Version-Release number of selected component (if applicable):
libvirt-0.6.2-12.fc11.x86_64
libvirt-python-0.6.2-12.fc11.x86_64
python-virtinst-0.400.3-8.fc11.noarch
qemu-0.10.5-3.fc11.x86_64
virt-manager-0.7.0-5.fc11.x86_64

How reproducible:
Reproducible.

Steps to Reproduce:
1. Start virt-manager
2. Create a new machine
3. In step 1, choose "Network Install (HTTP, FTP or NFS)"
4. In step 2, use an NFS URL like "nfs://somehost.domain.tld/.../fedora/11/Fedora/x86_64/os", then click on "Forward"
  
Actual results:
Error dialog titled "Input Error":

"""
Error setting install media location.

Privilege is required for NFS installations
"""

I'm never asked for any credentials which would possibly give me this privilege.

Expected results:
Possibly at this point, virt-manager/PolicyKit should prompt me to type in the root password to acquire the necessary authorization.

Additional info:
Comment 1 Mark McLoughlin 2009-07-03 10:01:14 EDT
Thanks Nils, putting this on F12VirtTarget since it's unlikely to be fixed for F-11

Doing this via PolicyKit sounds sane - it would be similar to how nautilus allows users to do NFS mounts, probably
Comment 2 Nils Philippsen 2009-07-06 05:57:03 EDT
Perhaps virt-manager could display a slightly more informative error message in the meantime. E.g. if it's running as non-root, tell the user that nfs installations aren't possible?
Comment 3 Mark McLoughlin 2009-09-22 09:55:59 EDT
Ah, I see we already had this filed - see bug #501922

*** This bug has been marked as a duplicate of bug 501922 ***

Note You need to log in before you can comment on or make changes to this bug.