Bug 50869 - Installer crashes if reiserfs filesystems found
Summary: Installer crashes if reiserfs filesystems found
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: roswell
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-04 02:20 UTC by Pawel Worach
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 22:52:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Installer traceback (8.04 KB, text/plain)
2001-08-04 10:16 UTC, Pawel Worach
no flags Details

Description Pawel Worach 2001-08-04 02:20:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.7-ac4 i686; Nav)

Description of problem:
The machine currently has slackware installed with all filesystems except
'/'
on reiserfs.

when using diskdruid to assingn the partitions to a filesystem this
happened:
/dev/hda1 which is ext2 now went ok justs selected the device typed '/' and
set filesystem options to reformat it to ext3.

the selecting /dev/hda2 as swap, no problems

then /dev/hda3 as /var (that currently is reiserfs) you can't enter a
mountpoint for it  because it's not a "known" filesystem so you have
to get to the filesystem options dialog to tell anaconda to reformat it
using ext2 or ext3, when you hit enter at the button the installer crashed.

all this was done using the text based installer in expert mode
and because i don't want to change the on-disk partitions i didn't delete
or
add any, I just wanted to reassign the existing ones to a filesystem and
reformat them
to ext3

How reproducible:
Always

Steps to Reproduce:
oh, please see description

Actual Results:  Installer crashed

Expected Results:  Installer popps up with the filesystem options dialaog.

Additional info:

workaround: remove all on-disk partitions, reboot.
create new disk partitions and filesystems so that 
anaconda doesn't find any reiserfs filesystems.

Comment 1 Matt Wilson 2001-08-04 03:16:13 UTC
is there a traceback?  if so, save it to a disk and upload it please.


Comment 2 Pawel Worach 2001-08-04 10:16:35 UTC
Created attachment 26212 [details]
Installer traceback

Comment 3 Matt Wilson 2001-08-06 19:08:37 UTC
verified.


Comment 4 Glen Foster 2001-08-06 22:52:02 UTC
We (Red Hat) really need to fix this defect before next release.

Comment 5 Jeremy Katz 2001-08-07 01:29:21 UTC
Thanks for the report.  Fixed in CVS


Note You need to log in before you can comment on or make changes to this bug.