Bug 508719 - setroubleshoot: SELinux is preventing kio_trash (hotplug_t) "search" boot_t.
setroubleshoot: SELinux is preventing kio_trash (hotplug_t) "search" boo...
Status: CLOSED DUPLICATE of bug 508718
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:b854540c808...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 12:04 EDT by Jerry Amundson
Modified: 2009-06-29 12:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 12:13:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry Amundson 2009-06-29 12:04:47 EDT
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing kio_trash (hotplug_t) "search" boot_t.

Detailed Description:

[SELinux is in permissive mode, the operation would have been denied but was
permitted due to permissive mode.]

SELinux denied access requested by kio_trash. It is not expected that this
access is required by kio_trash and this access may signal an intrusion attempt.
It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                unconfined_u:system_r:hotplug_t:s0
Target Context                system_u:object_r:boot_t:s0
Target Objects                / [ dir ]
Source                        kio_trash
Source Path                   /usr/bin/kdeinit4
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kdelibs-4.2.95-1.fc12
Target RPM Packages           filesystem-2.4.21-1.fc11
Policy RPM                    selinux-policy-3.6.20-1.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.30-0.1.2.32.rc8.xendom0.fc12.x86_64 #1 SMP Thu
                              Jun 4 17:46:39 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Mon 29 Jun 2009 08:57:28 AM CDT
Last Seen                     Mon 29 Jun 2009 08:57:28 AM CDT
Local ID                      d7bcc989-9100-4ddc-a967-c59ead9007da
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1246283848.253:39118): avc:  denied  { search } for  pid=2938 comm="kio_trash" name="/" dev=sda1 ino=2 scontext=unconfined_u:system_r:hotplug_t:s0 tcontext=system_u:object_r:boot_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1246283848.253:39118): arch=c000003e syscall=6 success=no exit=-2 a0=d97ea8 a1=7ffff64698f0 a2=7ffff64698f0 a3=2c items=0 ppid=2773 pid=2938 auid=2355 uid=2355 gid=100 euid=2355 suid=2355 fsuid=2355 egid=100 sgid=100 fsgid=100 tty=(none) ses=1 comm="kio_trash" exe="/usr/bin/kdeinit4" subj=unconfined_u:system_r:hotplug_t:s0 key=(null)


audit2allow suggests:

#============= hotplug_t ==============
allow hotplug_t boot_t:dir search;
Comment 1 Daniel Walsh 2009-06-29 12:13:10 EDT

*** This bug has been marked as a duplicate of bug 508718 ***

Note You need to log in before you can comment on or make changes to this bug.