Bug 50875 - NFS Installation: RedHat tree on remote CD is not recognized
NFS Installation: RedHat tree on remote CD is not recognized
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-04 03:14 EDT by giuseppe.angilella
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-04 03:15:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description giuseppe.angilella 2001-08-04 03:14:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16 i686)

Description of problem:
I'm trying to install RedHat Linux 7.1 (Guinness) on a HP Vectra N2 4/50i
(processor: 486, RAM: 16Mb, two HDs, 1 Gb each, floppy driver, built-in
Ethernet card, recognized as "AT1500, HP J2405A, most NE2100/clone", module
lance.o loaded correctly, when additional parameters io, irq, dma are
specified).

This rather old computer set is not provided with a CDROM reader, which I
then use remotely, exporting via NFS the CDROM reader of another computer,
wired to the same LAN.

I insert RedHat 7.1 disk 1 on /dev/cdrom of the new computer (NFS server
machine), mount
/mnt/cdrom, and export it, as specified in /etc/exportfs: /mnt/cdrom
vectra.mydomain.do(ro,no_root_squash,insecure). On the Vectra, I specify
the
name of the NFS server correctly, and specify /mnt/cdrom as the directory
containing the RedHat installation tree.

I let the installer mount such a remote path via NFS, and the mounting
procedure is successful, and is recorded as such by /var/log/messages in
the NFS server machine.

(Note: NFS exporting the same path to a third machine running linux gives
no
problem, i.e. I am pretty sure that the NFS server works well).

However, RedHat installer ends with the following error message: "The
directory specified does not contain a valid RedHat installation tree".

Note: I resorted to an older release of RedHat (6.2), and I am presently
performing an NFS installation between the same machines, which is giving
no problem. (Only, since I hadn't RedHat 6.2 physically present on a CD, I
mounted -o loop its iso image on /mnt/cdrom - which should be equivalent,
from the point of view of the Vectra).

How reproducible:
Always

Steps to Reproduce:
1. mount /mnt/cdrom with RedHat 7.1 disk 1 on /dev/cdrom of computer #1
2. make the bootnet floppy with dd if=bootnet.img of=/dev/fd0
3. add the line /mnt/cdrom vectra.mydomain.do(ro,no_root_squash,insecure)
    in /etc/exports and run exportfs (I tried also without insecure and/or
    without no_root_squash).
4. boot the old Vectra with the bootnet floppy
5. follow the initial steps of the installer
6. load the lance.o module with parameters (io, irq, dma) as specified by
    the BIOS (note: ping to Vectra from another machine performs well; the
    ethernet card is actually working and all the TCP/IP parameters are OK)
7. specify the address of the NFS server (computer #1) and the path of the
   Linux RedHat 7.1 distribution tree (the latter as: /mnt/cdrom)


Actual Results:  Mounting via NFS performs well (check: /var/log/messages
on computer #1), BUT the installer does not recognize that directory as
containing a valid RedHat installation tree.
	

Expected Results:  I expected that /mnt/cdrom were recognized as a valid
RedHat installation tree

Additional info:

The same procedure, when performed with an older RedHat distribution (6.2:
zoot), works without problems. Same steps as above. Only, I mount -o loop
the ISO image of disk 1 of RedHat 6.2 (since I haven't RH 6.2 CD any more),
but I mount it always on /mnt/cdrom.
Comment 1 Bill Nottingham 2001-08-05 20:33:28 EDT
For NFS installs, you need a full tree (i.e., both CDs). See the README at the
top level of the CD.

Note You need to log in before you can comment on or make changes to this bug.