Bug 508761 - System runs very hot with 2.6.31 kernels
System runs very hot with 2.6.31 kernels
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 14:24 EDT by birger
Modified: 2013-01-10 02:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-02 23:19:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description birger 2009-06-29 14:24:29 EDT
Description of problem:
I'm running on HP EliteBook 2530p with Fedora Rawhide x86_64. 4GB RAM and 80GB SSD

When I boot 2.6.31.* the fan comes on rather quickly, and the system gets uncomfortably hot. Running powertop I can make some observations
I usually see most of the cpu time in C6 state, now it's almost 50% C0.

I have almost 500 wakeups/sec, and > 90% are kernel core, where it used to be about a fifth, and most due to wlan driver.


Version-Release number of selected component (if applicable): 2.6.31


How reproducible: All kernels in this series I have tried so far.


Steps to Reproduce:
1. Boot a 2.6.31 kernel
2. Look at powertop output
3. Feel the heat
  
Actual results:


Expected results:


Additional info:
Comment 1 birger 2009-07-01 15:01:29 EDT
I just installed the 2.6.31-0.35.rc1.git5.fc12.x86_64 kernel, and the power usage is back to normal.

At the moment I have 87% in state C6 even if I am typing this in firefox running in wine. Power usage balances around 10W again. No fans running. Silence... :-)

Thanks for a quick fix

Note You need to log in before you can comment on or make changes to this bug.