Bug 508768 - KVM guests provisioning fails, qemu package needed
KVM guests provisioning fails, qemu package needed
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike McCune
Red Hat Satellite QA List
na
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2009-06-29 15:13 EDT by wes hayutin
Modified: 2014-07-04 09:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-04 09:26:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-06-29 15:13:06 EDT
Description of problem:

6/26 build

client is a x86_64 rhel 53

ng></value>\n</param>\n<param>\n<value><string>/var/lib/xen/weskvm01</string></value>\n</param>\n<param>\n<value><string> ksdevice=eth0 </string></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 4314}
D: handle_action actionid = 4314, version = 2
D: do_call kickstart_guest.initiate ('grandprix.rhndev.redhat.com', 'sat-blade-6.idm.lab.bos.redhat.com:82:weskvm01', 'qemu', 764, 'weskvm01', 512, 1, 3, 'xenbr0', '/var/lib/xen/weskvm01', ' ksdevice=eth0 ')
- looking for Cobbler at http://grandprix.rhndev.redhat.com/cobbler_api
- reading URL: http://grandprix.rhndev.redhat.com/cblr/svc/op/ks/system/sat-blade-6.idm.lab.bos.redhat.com:82:weskvm01
install_tree: http://grandprix.rhndev.redhat.com/ty/QIErkPSJ
qemu package needs to be installed
D: Sending back response (1, 'Virtual kickstart failed. Koan error.', {'koan': 'qemu package needs to be installed'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or package list recently updated)', {})
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: May free Score board((nil))
Comment 1 Mike McCune 2009-07-01 15:42:56 EDT
To resolve this you need:

* your system subscribed to: rhel-x86_64-server-vt-5-beta
* the kvm-qemu-img.x86_64 package installed

We can possibly auto-install kvm-qemu-img if we detect you are schedule a KS of a guest using KVM because we can't have koan or spacewalk-koan require the package since this won't work on RHEL Hosts using xen.
Comment 2 Mike McCune 2009-07-01 18:38:17 EDT
I vote we punt this off to a later release after looking at this some more.  I hesitate to auto-install kvm-qemu-img because that is just one of the required pieces for KVM virtualization to work.  Others include libvirt, virt-manager, etc...

Ideally we would have Satellite validate the state of your host to check the required RHEL virt packages:

libvirt
xen (if doing xen)
qemu (if doing kvm)

we could then setup package installs, start libvirtd, etc..

Not something we can do in 530 thou.
Comment 3 Clifford Perry 2009-07-02 14:08:37 EDT
Based on comments, it seems that we anticipate folks to correctly have needed packages installed for Virt for an already installed system if they plan to use it as a virt host. Sure, we should and could do more/better checking for Xen and/or KVM components being installed to validate, but for now, moving off 530. 

Cliff

Note You need to log in before you can comment on or make changes to this bug.