Bug 50878 - login with tcsh as shell sometimes causes an error
Summary: login with tcsh as shell sometimes causes an error
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: bash   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-04 10:37 UTC by CoreDump
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-29 18:24:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description CoreDump 2001-08-04 10:37:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.2-2 i586)

Description of problem:
Sometimes when i log on from a console i get this error message:
Warning: no access to tty (Inappropriate ioctl for device).
Thus no job control in this shell.

If i get such a crippled shell, i can't use several functions like command
history and command completion.
So far i couldn't reproduce this bug with the bash shell, but i'm not
completely sure if tcsh is the real source of this bug.


How reproducible:
Sometimes

Steps to Reproduce:
1. log out
2. try to log in from a virtual console


Additional info:

Comment 1 CoreDump 2001-09-02 09:46:42 UTC
The bug seems to be fixed by upgrading a few packages to the newest rawhide.
(filesystem, glibc, etc). I don't know which one caused the bug, but it seems to
be fixed. At least it isn't a bug in tcsh.


Comment 2 CoreDump 2001-10-29 18:24:36 UTC
The problem reappeared when i upgraded to bash-2.05-10!
Last known good version was bash-2.05-9.


Comment 3 Bernhard Rosenkraenzer 2002-08-30 01:04:07 UTC
Not reproducable on 7.3 and rawhide


Note You need to log in before you can comment on or make changes to this bug.