Bug 508805 - thunderbird 3.0 with lightning 1.0pre periodically 'exits'
thunderbird 3.0 with lightning 1.0pre periodically 'exits'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sunbird (Show other bugs)
11
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 20:17 EDT by Bob Relyea
Modified: 2009-08-19 12:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-19 12:51:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Relyea 2009-06-29 20:17:06 EDT
Description of problem:
Thunderbird with lightning installed randomly closes. No Talkback window is created.


Version-Release number of selected component (if applicable):

thunderbird-lightning-1.0-0.3.20090302hg.fc11.x86_64
thunderbird-3.0-2.3.beta2.fc11.x86_64
xulrunner-1.9.1-0.20.beta4.fc11.x86_64


How reproducible:

On my system (x86 Laptop running Fedora 11 upgrade install from Fedora 10) it happens between 3-5 times a day (sometimes just minutes apart).

I'm connected to 2 IMAP servers simultaneously:
   1) a Zimbra imap server.
   2) a dovecot server running of Fedora 7.

In Lighting I'm connected to multiple calendars, including calendars from:
   1) Zimbra.
   2) Apache Web/DAV.
  
Actual results:

Crash after the following error message:

pure virtual method called
terminate called without an active exception


The stack traceback (collected from gdb):

(gdb) where
#0  0x00000031928332f5 in raise () from /lib64/libc.so.6
#1  0x0000003192834b20 in abort () from /lib64/libc.so.6
#2  0x000000319cec3e15 in __gnu_cxx::__verbose_terminate_handler() ()
   from /usr/lib64/libstdc++.so.6
#3  0x000000319cec2236 in ?? () from /usr/lib64/libstdc++.so.6
#4  0x000000319cec2263 in std::terminate() () from /usr/lib64/libstdc++.so.6
#5  0x000000319cec2b3f in __cxa_pure_virtual () from /usr/lib64/libstdc++.so.6
#6  0x00007ffff0949ff0 in nsImapMockChannel::QueryInterface (
    this=0x7fffbfcbc1d8, aIID=@0xfe4, aInstancePtr=0x7fffffffd2c8)
    at /usr/src/debug/thunderbird-3.0/mailnews/imap/src/nsImapProtocol.cpp:8144
#7  0x000000319de39286 in nsQueryInterfaceWithError::operator() (
    this=0x7fffffffd2e0, aIID=@0xfe4, answer=0x6) at nsCOMPtr.cpp:64
#8  0x000000319de39346 in nsCOMPtr_base::assign_from_qi_with_error (
    this=0x7fffffffd2f0, qi=@0xfe4, iid=@0xfe4) at nsCOMPtr.cpp:105
#9  0x000000319de3af15 in nsCOMPtr (qi=<value optimized out>, 
    this=<value optimized out>) at ../../dist/include/xpcom/nsCOMPtr.h:580
#10 NS_GetWeakReference (qi=<value optimized out>, this=<value optimized out>)
    at nsWeakReference.cpp:108
#11 0x00007ffff097316a in do_GetWeakReference (error=<value optimized out>, 
    aRawPtr=<value optimized out>)
    at ../../../mozilla/dist/include/xpcom/nsIWeakReferenceUtils.h:110
#12 nsImapUrl::SetMockChannel (error=<value optimized out>, 
    aRawPtr=<value optimized out>)
---Type <return> to continue, or q <return> to quit---
    at /usr/src/debug/thunderbird-3.0/mailnews/imap/src/nsImapUrl.cpp:1181
#13 0x00007ffff092a9d3 in nsImapIncomingServer::RetryUrl (this=0x7fffe7721e00, 
    aImapUrl=0x7fffc0422000, aChannel=0x6)
    at /usr/src/debug/thunderbird-3.0/mailnews/imap/src/nsImapIncomingServer.cpp:454
#14 0x000000319de78465 in NS_InvokeByIndex_P (that=0xfe4, methodIndex=4068, 
    paramCount=6, params=0xffffffffffffffff)
    at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_x86_64_linux.cpp:208
#15 0x000000319de70ddb in nsProxyObjectCallInfo::Run (this=0x7fffbfa2a300)
    at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/proxy/src/nsProxyEvent.cpp:181
#16 0x000000319de6cab5 in nsThread::ProcessNextEvent (this=0x7ffff7c480d0, 
    mayWait=1, result=0x7fffffffd51c)
    at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/threads/nsThread.cpp:510
#17 0x000000319de3d984 in NS_ProcessNextEvent_P (thread=0xfe4, mayWait=4068)
    at nsThreadUtils.cpp:227
#18 0x00007fffee6d2591 in nsBaseAppShell::Run (this=0x7ffff116efa0)
    at /usr/src/debug/thunderbird-3.0/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:170
#19 0x00007fffed7d18a2 in nsAppStartup::Run (this=0x7fffee998040)
    at /usr/src/debug/thunderbird-3.0/mozilla/toolkit/components/startup/src/nsAppStartup.cpp:192
---Type <return> to continue, or q <return> to quit---
#20 0x000000319e2195ca in XRE_main (argc=<value optimized out>, 
    argv=<value optimized out>, aAppData=<value optimized out>)
    at /usr/src/debug/thunderbird-3.0/mozilla/toolkit/xre/nsAppRunner.cpp:3279
#21 0x00000000004019bc in main (argc=1, argv=0x7fffffffdd58)
    at /usr/src/debug/thunderbird-3.0/mail/app/nsMailApp.cpp:103



Expected results:

No crash...;)


Additional info:

should be inline.
Comment 1 Lubomir Rintel 2009-06-30 05:05:18 EDT
I'm wondering if you can reproduce this with upstream's nightly builds?
Comment 2 Bob Relyea 2009-06-30 14:21:26 EDT
I'll try this this afternoon. I'm going to go dark for a couple of week (vacation).

I think Zimbra seems to be a key part. I was running with only dovecot/apache last night with no problems.

bob
Comment 3 Bob Relyea 2009-07-17 18:15:54 EDT
So I've been away on vacation for 2 weeks. During those two weeks I ran thunderbird+lightning against a dovecot/apache server without any exits.

On return I've turned of lightning and run only thunderbird talking to Zimbra (+dovecot). Even without lightning I am getting thunderbird exits, so I think the component should probably be changed back. This does not appear to be a lightning problem...

bob
Comment 4 Bob Relyea 2009-07-22 11:21:14 EDT
running the upstream nightly builds against the same profile does not randomly exit. The upstream nightly does not load lightning, but I believe we've exhonerated lightning a part of the problem.

bob
Comment 5 Bob Relyea 2009-08-19 12:51:17 EDT
I've been running the new version of thunderbird now for 36 hours (24 hours with lightning enabled) without exit, so I think this is closed now.

Note You need to log in before you can comment on or make changes to this bug.