This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 508865 - sVirt does not allow me to use ro nfs4 mount for iso image
sVirt does not allow me to use ro nfs4 mount for iso image
Status: CLOSED DUPLICATE of bug 509834
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 06:29 EDT by Gene Czarcinski
Modified: 2009-07-06 09:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-06 09:45:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2009-06-30 06:29:02 EDT
Description of problem:

I do not understand just what and how sVirt is trying to protect resources by changing the fcontext for the CD/DVD iso image file (or /dev/sr0 for that matter).

Given that an iso file is globally read-only on a host, I do not see this context change does much .. non-root users (owners and non-owners) can still copy the iso image file.

This is very confusing ... I just do not understand what is being protected and from whom!

However, this "zeal" to change the file's context also causes a problem when I try to use an iso image on another system through a read-only nfs4 mount.

When I tried this, the virt-managers guest creation wizard dies with the following:

-----------------------------------
Unable to complete install '<class 'libvirt.libvirtError'> internal error Domain f11-64 didn't show up

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 1501, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 541, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 633, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 974, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error Domain f11-64 didn't show up

'
-----------------------------------


I also tried doing this by using a symbolic link in the /var/lib/libvirt/images directory which pointed to the read-only mounted nfs4 filesystem and the result was pretty much the same:

----------------------------------
Unable to complete install '<class 'libvirt.libvirtError'> internal error Domain f11-tst1 didn't show up

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 1501, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 541, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 633, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 974, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error Domain f11-tst1 didn't show up

'
----------------------------------
**********************************
Just because SELinux is there does not mean that it is an appropriate protection mechanism (and I am very much an SELinux fan!!)
**********************************
Version-Release number of selected component (if applicable):
libvirt-0.6.2-12.fc11.x86_64
selinux-policy-3.6.12-57.fc11.noarch (from updates-testing)
Comment 1 Mark McLoughlin 2009-07-03 10:25:05 EDT
Please try libvirt-0.6.2-13.fc11 from updates-testing, this sounds like it might be a dup of bug #507555

If it still fails, please provide /var/log/libvirt/qemu/$guest.log
Comment 2 Gene Czarcinski 2009-07-06 09:45:29 EDT
Closed because new report is better

*** This bug has been marked as a duplicate of bug 509834 ***

Note You need to log in before you can comment on or make changes to this bug.