Bug 508868 - .treeinfo data for rawhide x86_64 is confused about architecture
.treeinfo data for rawhide x86_64 is confused about architecture
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 06:41 EDT by Stefan Assmann
Modified: 2013-01-10 00:16 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-03 10:28:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Assmann 2009-06-30 06:41:37 EDT
Description of problem:
When I try to make a network installation of rawhide from the URL http://ftp.uni-erlangen.de/pub/Linux/MIRROR.fedora/core/development/x86_64/os/ it fails with the following error:
Unable to complete install '<class 'ConfigParser.NoSectionError'> No section: 'images-i386'
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 1501, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 539, in start_install
    self._prepare_install(meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 594, in _prepare_install
    meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/DistroInstaller.py", line 233, in prepare
    self._prepare_kernel_and_initrd(guest, distro, meter)
  File "/usr/lib/python2.6/site-packages/virtinst/DistroInstaller.py", line 182, in _prepare_kernel_and_initrd
    type=self.os_type, distro=distro)
  File "/usr/lib/python2.6/site-packages/virtinst/OSDistro.py", line 133, in acquireKernel
    scratchdir, type, distro)
  File "/usr/lib/python2.6/site-packages/virtinst/OSDistro.py", line 119, in _acquireMedia
    return (store.acquireKernel(guest, fetcher, progresscb),
  File "/usr/lib/python2.6/site-packages/virtinst/OSDistro.py", line 215, in acquireKernel
    kernelpath = self._getTreeinfoMedia("kernel")
  File "/usr/lib/python2.6/site-packages/virtinst/OSDistro.py", line 272, in _getTreeinfoMedia
    return self.treeinfo.get("images-%s" % t, mediaName)
  File "/usr/lib64/python2.6/ConfigParser.py", line 531, in get
    raise NoSectionError(section)
NoSectionError: No section: 'images-i386'
'

However making an installation of F11 from this URL http://ftp.uni-bayreuth.de/linux/fedora/linux/releases/11/Fedora/x86_64/os/ works fine


Version-Release number of selected component (if applicable):
virt-manager-0.7.0-5.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. try to network install rawhide from the following URL http://ftp.uni-erlangen.de/pub/Linux/MIRROR.fedora/core/development/x86_64/os/

  
Actual results:
fails to create VM

Expected results:
succeeds to create VM

Additional info:
Comment 1 Daniel Berrange 2009-06-30 06:53:33 EDT
The rawhide repo you have there has totally fubar  .treeinfo file

http://ftp.uni-erlangen.de/pub/Linux/MIRROR.fedora/core/development/x86_64/os/.treeinfo


Your tree there is x86_64, but the .treeinfo file is claiming its i386, and more over the data is still incomplete, missing the 'images-x86_64' section that you would expect for x86_64. Either the mirror you're using is broken, or the tool that created rawhide spins is broken. 


Changing component to pungi, because that's my best guess as to what tools responsible for .treeinfo generation. Do re-assign elsewhere if I'm wrong.
Comment 2 Mark McLoughlin 2009-07-03 10:28:42 EDT
It's actually anaconda's buildinstall, and it seems fixed now, although I don't see any obvious fixes in anaconda.git

Note You need to log in before you can comment on or make changes to this bug.