Bug 508875 - S-c-tools cleanup: Do not use colors
S-c-tools cleanup: Do not use colors
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-lvm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Marek Grac
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 493605
  Show dependency treegraph
 
Reported: 2009-06-30 07:26 EDT by Roman Rakus
Modified: 2014-01-12 19:09 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-30 05:14:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Rakus 2009-06-30 07:26:14 EDT
Description of problem:
There are used too much colors in tree view (on the left), in the properties frame...

How reproducible: 

Steps to Reproduce:
1. 
2. 
3. 

Actual results:
Too much colors.

Expected results:
Just only standard colors

Additional info:
This bug report is part of "System Configuration Tools Cleanup Project". Don't
hesitate to ask project maintainers for any kind of help.
Comment 1 Marek Grac 2009-08-17 13:12:55 EDT
Which are the standard colors?

On the left we have: black, red (for physical level), light blue (for logical level) and purple (label only - clustered). Removing any other color then purple will cause loss of information.
Comment 2 Jaroslav Reznik 2009-08-18 03:48:20 EDT
We don't want to remove purple color, we're not against purple, we like purple ;-)

What we want is to not use any colors in left treeview and especially in properties view. It's ok to let them in main graphical view.

The reason is that it doesn't look good, especially light blue is bad readable on white background. And it could case problems if user has another color scheme (I'm not sure if you are handling this in the code). Maybe some other solution would be better like different icons for PV, LV, VG etc?
Comment 3 Marek Grac 2009-10-30 05:14:07 EDT
System-config-lvm is entering maintainance-only mode and whole package will be deprecated. We do not plan active development, only bugfixing.

Note You need to log in before you can comment on or make changes to this bug.