Bug 508882 - removing of strange languages support will remove OO
removing of strange languages support will remove OO
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 08:08 EDT by Marcela Mašláňová
Modified: 2014-01-21 18:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-06 22:54:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2009-06-30 08:08:01 EDT
My system was minimal install, so many language support must be drag in by some strange requirement. However, the main problem is removal of some groups. I tried remove some really strange:
yum groupremove "Venda Support" "Inuktitut Support" "Kannada Support"
which try to remove OO and some others.
http://pastebin.test.redhat.com/12602

And weird things about groups are also here:
yum groupremove "Electronic Lab"
which ends with removal of qemu
http://pastebin.test.redhat.com/12603

If I installed qemu package then I don't anticipate installation of Electronic group. I suppose the group shouldn't be mentioned as installed, in case one package from group was installed. Also the bunch of language support doesn't make sense.
Comment 1 Daniel Mach 2009-06-30 08:16:39 EDT
I think the problem is in how yum handles groups.
If you have a single package from a group installed, that group is considered as installed too.
This is IMO bad. The group list doesn't match with groups installed by anaconda.

Yum should make difference between yum install package vs yum groupinstall group (or yum install @group).
Comment 2 seth vidal 2009-06-30 09:53:47 EDT
No, that's not how yum handles group.

If a group has NO mandatory and NO default pkgs, then any optional pkg installed marks the group as installed.

if a group has NO mandatory pkgs then if all of the default pkgs are installed then the group is installed

if a group has mandatory pkgs then only if all of the mandatory pkgs are installed then the group is installed.

yes, we know the groups concept is sub-optimal but the sets of ways to change it are limited.
Comment 3 Adam Miller 2009-07-06 22:54:21 EDT
This is as designed as Seth described.

Note You need to log in before you can comment on or make changes to this bug.