Bug 508917 - Cluster inconsistencies if data sent after a connection is closed.
Cluster inconsistencies if data sent after a connection is closed.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1.1
All Linux
high Severity high
: 1.1.6
: ---
Assigned To: Alan Conway
Frantisek Reznicek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 10:22 EDT by Alan Conway
Modified: 2015-11-15 19:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-10 09:01:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Modified unit test that exposes the issue. (39.09 KB, text/x-c++src)
2009-06-30 10:22 EDT, Alan Conway
no flags Details
Patch for qpidd-0.5.752581-20 (20.70 KB, patch)
2009-06-30 17:11 EDT, Alan Conway
no flags Details | Diff

  None (edit)
Description Alan Conway 2009-06-30 10:22:23 EDT
Created attachment 349957 [details]
Modified unit test that exposes the issue.

Description of problem:

If a client is using a connection that is closed at the broker end because of an error, there is a race condition that allows the connection to be incorrectly re-created on replica brokers which can cause those brokers to exit with an error that does not occur on the directly connected broker.

Version-Release number of selected component (if applicable):


How reproducible: easy


Steps to Reproduce:

Run attached modified version of cluster_test.cpp in a loop.
  
Actual results:

Exit with error "channel 2 not attached."

Expected results:

No error

Additional info:
Comment 1 Alan Conway 2009-06-30 17:11:04 EDT
Created attachment 350022 [details]
Patch for qpidd-0.5.752581-20

Patch for the 1.1.6 release.
Comment 2 Alan Conway 2009-06-30 17:11:39 EDT
Also committed to trunk r789947
Comment 3 Alan Conway 2009-07-01 09:44:44 EDT
Patch includes XML changes.
Comment 4 Gordon Sim 2009-07-10 09:01:22 EDT
It is suspected that this was only exhibited on a development build and never in a  n official package set.

A similar error is reported in https://bugzilla.redhat.com/show_bug.cgi?id=510722 that was produced on published packages.

Note You need to log in before you can comment on or make changes to this bug.