Bug 508932 - anaconda misparses bind mounts
anaconda misparses bind mounts
Status: CLOSED DUPLICATE of bug 506396
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 11:14 EDT by Ralf Corsepius
Modified: 2009-06-30 11:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 11:22:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photo of screen, from a failing "upgrade" (98.37 KB, image/jpeg)
2009-06-30 11:16 EDT, Ralf Corsepius
no flags Details

  None (edit)
Description Ralf Corsepius 2009-06-30 11:14:26 EDT
Description of problem:

anaconda, as on the F11-CDs/DVDs, is unable to parse bind-mounts from fstab.
Instead of correctly processing them, it fails badly and aborts.

This significantly reduces usability of the CDs/DVDs for upgrading existing installations and using the F11-CDs/DVD's "rescue mode".


Version-Release number of selected component (if applicable):
anaconda-11.5.0.59-1.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. On an FC10 system, add a "bind" mount to /etc/fstab
E.g.
...
/dev/VolGroup01/LogVol02 /home         ext3    defaults        1 2
/home/ftp/pub  /var/ftp/pub            none    bind
..

2. Reboot with F11 DVDs

Alternative: Add bind-mounts to /etc/fstab and try to boot from DVD in "rescue mode".


Actual results:
"upgrading" or "rescue installed system" aborts with:

"An error occurred mounting device /mnt/sysimage/home/home/ftp/pub as /var/ftp/pub: device /mnt/sysimage/home/home/ftp/pub does not exist"

(Note the duplicate /home)

Expected results:
Function.
Comment 1 Ralf Corsepius 2009-06-30 11:16:42 EDT
Created attachment 349961 [details]
Photo of screen, from a failing "upgrade"
Comment 2 Chris Lumens 2009-06-30 11:22:55 EDT

*** This bug has been marked as a duplicate of bug 506396 ***

Note You need to log in before you can comment on or make changes to this bug.