Bug 508955 - SSE registers and ptrace problem
SSE registers and ptrace problem
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 12:14 EDT by Tom Horsley
Modified: 2009-07-08 08:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-08 08:45:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2009-06-30 12:14:47 EDT
Description of problem:

I don't have a small test case yet (I'll attach it when I do), but something
in the vicinity of the SSE registers and debugging operations is screwed
up. I have a debugger regression test that fails in x86_64 fedora 11 and
passes on the exact same machine running the exact same debugger in
x86_64 fedora 10.

The symptom is that a xmm register I modify with ptrace pokeuser
does not show up with the same value in the process when I run it later,
but the details are complex, and I haven't made a simple case fail yet.

I just thought I'd go ahead and create this bugzilla in case someone else
runs across the problem or knows it is already fixed in an upcoming kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.29.5-191.fc11.x86_64

How reproducible:
every time in my complicated testbed

Steps to Reproduce:
1.run testbed
2.see failure (no much help, I know).
3.
  
Actual results:
Just to give an example, the debugged process that has been modified
winds up printing:
patched output = 5.4902e-315

Expected results:
When if the register modification had worked, it would have printed:
patched output = 47

Additional info:
On fedora 10, the kernel that worked was:
kernel-2.6.27.25-170.2.72.fc10.x86_64

There are also many other linux distributions which run the test with
no failures.
Comment 1 Chuck Ebbert 2009-07-02 23:14:26 EDT
(In reply to comment #1)
> There are also many other linux distributions which run the test with
> no failures.  

With 2.6.29 kernels?
Comment 2 Tom Horsley 2009-07-02 23:32:28 EDT
Probably not. I think fedora 11 is the only one with a 2.6.29 kernel,
but I'm also very confused by what I'm seeing while trying to track
down the specific bug - I still don't have a clue what is actually
going wrong, sometimes I think it might be a gcc code generation
problem rather than a kernel problem - fedora 11 may also be the only linux
I've tried it on with a 4.4 gcc (I haven't checked for sure).
Comment 3 Tom Horsley 2009-07-08 08:45:23 EDT
OK, I'm still confused as ever about why this only fails on fedora 11,
but I'm now pretty positive that whatever is going on has nothing to do
with the kernel, so I'm gonna close this as notabug.

Sorry for the noise :-).

Note You need to log in before you can comment on or make changes to this bug.