Bug 508981 - dhclient appears to ignore send host-name
dhclient appears to ignore send host-name
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 14:15 EDT by Richard Henderson
Modified: 2009-08-06 10:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-06 10:23:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard Henderson 2009-06-30 14:15:57 EDT
Description of problem:
Trying to work around BZ#488975 i.e. get a hostname sent to the DHCP server in order for DDNS to function properly, I create /etc/dhclient-wlan0.conf with

send host-name "fred"

which does in fact get propagated across to /var/run/nm-dhclient-wlan0.conf.
Looking at the logs on the server side, the host-name option does not appear.

Interestingly, if I run dhclient manually, and use the -H option, the server does get fed the host-name option.


Version-Release number of selected component (if applicable):
dhclient-4.1.0-20.fc11.x86_64
Comment 1 David Cantrell 2009-06-30 15:25:27 EDT
Put your dhclient.conf files in /etc/dhcp rather than just /etc.  Yes, this is a change from what we've always had, but I wanted to collect all dhcp-related configuration files for dhcpd and dhclient and place them in a subdirectory because I felt like it was cluttering up /etc too much.

The dhclient(8) man page mentions the default config file path too:

       -cf <config-file>
              Path  to  the  client  configuration  file.  If unspecified, the
              default /etc/dhcp/dhclient.conf is used.
Comment 2 Richard Henderson 2009-06-30 16:15:56 EDT
That's not the problem -- NetworkManager *is* provding the -cf option, as described in my original report.
Comment 3 David Cantrell 2009-08-05 21:01:24 EDT
My mistake for misreading the first comment.  Do you have a semicolon on the end of the send host-name line in your dhclient-wlan0.conf file?

send host-name "fred";
Comment 4 Richard Henderson 2009-08-06 10:23:11 EDT
Oh good grief.  Well that's one for each of us mis-reading.
Chalk this up to user error, and thanks.

Note You need to log in before you can comment on or make changes to this bug.