This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 508987 - [Patch suggest] The Fedora machine dont join in Active Directory using ADS method.
[Patch suggest] The Fedora machine dont join in Active Directory using ADS me...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 516996
  Show dependency treegraph
 
Reported: 2009-06-30 14:25 EDT by Renato Krause
Modified: 2010-06-28 09:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:24:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
renatokrause: fedora_requires_release_note+


Attachments (Terms of Use)
Patch for include ads word in command if ads method is selected. (166 bytes, patch)
2009-06-30 14:29 EDT, Renato Krause
no flags Details | Diff

  None (edit)
Description Renato Krause 2009-06-30 14:25:05 EDT
Description of problem:
The entire procedure described below was reproduced in the same way performed in CentOS 5.3, which has the same utility: authconfig. CentOS in this whole procedure is successful in its objective. All fields were filled exactly the same but the machine was not joined the domain. Running the "system-config-authentication" from the terminal and noticed it was generating an error output as referencing the need to inform the method between the "net" and "join". Thus I wrote the attach solution for this issue. Please, contact me for any doubts.

Steps to Reproduce:
1. Run "system-config-authentication" as root
2. Check "Enable Winbind support"
3. Click "Configure Winbind"
4. Fill all fields 
5. Click "Join Domain"
6. Save
7. Fill the user and pass fields
8. Click "ok"
  
Actual results:
Not happens.

Expected results:
The Fedora machine join in Active Directory domain.

Additional info:
The name of actions, fields and buttons may be different because I'm running the Brazilian Portuguese version of Fedora 11.
Comment 1 Renato Krause 2009-06-30 14:29:29 EDT
Created attachment 349998 [details]
Patch for include ads word in command if ads method is selected.
Comment 2 Tomas Mraz 2009-07-01 04:44:16 EDT
Are you sure that adding the ads option helps? It is weird that samba does not autodetect the method.

Simo, how net join autodetects the method to use in join command?
Comment 3 Renato Krause 2009-07-01 08:39:24 EDT
Tomas,

Firstly thank you for your attention and for your quick response. 
As the man page of the net: 

"[RPC | ADS] JOIN [TYPE] [-U username [% password]] [createupn = UPN] "

and 

"If this argument is omitted, net will try to determine it automatically. "

Therefore, we can see that the ADS parameter can be specified and if not it will be given automatically. What happens is that in Fedora 11 and my environment is not automatically determined. Or I use the package with this change or I get the command that tried to run and run with the ADS parameter. 
It may seem a flourish but in my environment it is very important.

Thanks again. I confirm my availability for any question.
Comment 4 Renato Krause 2009-07-02 16:36:24 EDT
I ve read some materials about and by which I understand is necessary to explicitly when ADS when not get a ticket through the "kinit".
Comment 5 Simo Sorce 2009-07-02 16:55:20 EDT
(In reply to comment #2)
> Are you sure that adding the ads option helps? It is weird that samba does not
> autodetect the method.
> 
> Simo, how net join autodetects the method to use in join command?  

Generally it uses DNS (and perhaps cldap) to discover if the DC is an Active Directory Domain Controller, if so it tries to use the ADS method, otherwise it falls back to the RPC method.
Comment 6 Tomas Mraz 2009-07-03 03:58:11 EDT
I'm still not quite sure that adding the ads to the command line is appropriate. It might break it for another users.
Comment 7 Renato Krause 2009-07-03 08:52:55 EDT
I could not imagine what would broke because I am expliciting ADS option selected by the user (it is what he want). Either way I would like to thank you Tomas and Simo by the attention. My patch was proposed because the changes what I do I often share. Feel free to contact me when need or feel comfortable. Greetings.
Comment 8 Renato Krause 2009-07-03 08:56:49 EDT
Simo,
Only a question:

Do you have any idea why it's not the use ADS method if I am explicit the three Active Directory Domain Controller we have?

Thanks one more time.
Comment 9 Simo Sorce 2009-07-03 10:34:42 EDT
I don't know, it's a question for Tomas.
Comment 10 Renato Krause 2009-07-04 22:04:44 EDT
Do you know Tomas?
Comment 11 Tomas Mraz 2009-07-06 15:52:19 EDT
This is a question for samba developers - why the ads method is not automatically used in the join command when the security = ads in the smb.conf.
Comment 12 Simo Sorce 2009-07-06 16:01:09 EDT
Adding guenther, he knows net join in and out.
Comment 14 Bug Zapper 2010-04-27 11:22:58 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Bug Zapper 2010-06-28 09:24:11 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.