Bug 509032 - Package profile syncs during kickstart, regardless of delta size, appear to be non-functional
Package profile syncs during kickstart, regardless of delta size, appear to b...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Justin Sherrill
Tomas Lestach
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-06-30 18:54 EDT by Steve Salevan
Modified: 2009-09-10 15:27 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:27:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-06-30 18:54:54 EDT
Description of problem:
If a user provisions a stock RHEL 5.3 machine from a Satellite, installs several packages (~5) from the Satellite's repos (creating a small delta), creates a package profile based off of this system, and then attempts to kickstart it, syncing it to this package profile, the sync will fail.

Version-Release number of selected component (if applicable):
530, 6/25 release

How reproducible:
Always

Steps to Reproduce:
1. Provision a machine to an @Base installation of RHEL 5.3 via Satellite
2. Install several packages on this machine from the Satellite when it comes up again
3. Create a package profile based upon the system after the installation completes
4. Create a new kickstart profile, identical to the one used in step 1, except link it to this new package profile
5. Kickstart the machine again
  
Actual results:
Package profile sync fails

Expected results:
Package profile sync succeeds

Additional info:
Comment 2 Justin Sherrill 2009-07-15 13:50:56 EDT
So I'm moving this bug to On_QA as it seems to work.  When I initiate a
kickstart with a package profile sync  it works just fine.
 that being said here are the caveats:


- Use RHEL 5 

The RHEL 4 client is fairly broken in several ways.  
 - Anything prior to RHEL 4u8's up2date client will not upload package arch
information.  A package profile without arch information will not work, it
errors out.  
 - The RHEL 4u8 client will not include up2date or rhnlib in it's package
profile.  This will cause very bad things, especially when the package profiles
themselves are missing up2date and rhnlib.
 - The RHEL 4u8 client will not include arch information if you do an 'up2date
foo' method of installing  a package (this will cause that package to be
ignored during the sync)


So when testing and actually using, I would highly recommend using RHEL 5.
Comment 3 Tomas Lestach 2009-07-16 11:20:47 EDT
Verified with Satellite-5.3.0-RHEL5-re20090707.0.

I verified the scenario described in #Description.

Note: Because some of the packages were not signed, the package install process
failed. After I disabled gpgcheck on the kickstarted machine and rescheduled
failed events again, package install
Comment 4 Steve Salevan 2009-07-31 16:25:28 EDT
RELEASE_PENDING from 7/24 build.
Comment 5 Brandon Perkins 2009-09-10 15:27:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.