Bug 509034 - kernel-2.6.spec file missing xen appendage to the xen package
kernel-2.6.spec file missing xen appendage to the xen package
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.3
All Linux
low Severity urgent
: rc
: ---
Assigned To: Don Zickus
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 19:04 EDT by Bret Palsson
Modified: 2011-03-24 11:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-24 11:36:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bret Palsson 2009-06-30 19:04:52 EDT
Description of problem:
Many packages with have a kernel-xen-XXXX dependancy because they were built with that kernel. However they return:

Error: Missing Dependency: kernel-xen = 2.6.18-128.1.14.el5xen is needed by package ...

This is because in the kernel-2.6.spec under Package xen it is missing the xen appendage.

If you install kernel-xen and type in `uname -r` it will output 2.6.18-128.1.14.el5xen which is the same command many spec files use to set the dependency of the kernel.

kernel-2.6.spec

Version-Release number of selected component (if applicable):
5.3

How reproducible:
Every time

Steps to Reproduce:
1. yum install kernel-xen
2. reboot
3. uname -r (note output)
4. yum list kernel-xen (note the xen is missing from the version)
  
Actual results:
The versions are a miss-match.

Expected results:
The versions should match.

Additional info:
I appended xen on the provides for the package xen in the spec file and then rebuilt, it now works.
I would suggest adding another Provides line and then have the appendage.
Comment 2 Don Zickus 2009-07-01 10:45:23 EDT
Hi Bret,

I think I know what you are looking for but I has hoping for some more concrete details just to make sure.

Is the patch you are suggesting something like (sorry for the cut-n-paste)?

@@ -924,6 +929,7 @@ Summary: The Linux kernel compiled for Xen VM operations

 Group: System Environment/Kernel
 Provides: kernel = %{version}
+Provides: kernel = %{version}xen
 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xen
 Provides: xen-hypervisor-abi = %{xen_abi_ver}
 Prereq: %{kernel_prereq}


Also, may I ask what packages you are having trouble with this dependency.  This is the first I have heard of it.  I would have assumed this issue would have been brought up a while ago.  But then again, we are creating new virt packages all the time.

Thanks,
Don
Comment 3 Don Zickus 2009-11-24 11:12:18 EST
Hi Bret,

Any feedback on my above reply?
Comment 4 Bret Palsson 2009-11-24 11:26:54 EST
Yes that looks correct. I don't remember what package I was having a problem with now. I did however repackage the RPM with the above patch file. Sorry I didn't submit one earlier.

Thanks,
Bret
Comment 5 Laszlo Ersek 2011-03-24 11:36:02 EDT
$ uname -r
2.6.18-238.el5xen

$ yum list kernel-xen
kernel-xen.x86_64        2.6.18-238.el5           installed

The package is called "kernel-xen", not "kernel". I believe the affected client packages should depend (alternatively anyway) on the "kernel-xen" package, not on "kernel" with a "xen" suffixed version. Thus it's rather those packages that should be modified. Since no specific package was named, I'm closing this as NOTABUG. Please reopen if you disagree. Thank you.

Note You need to log in before you can comment on or make changes to this bug.