Bug 509037 - If base channel with rhncfg packages exists, activation key config deploy adds base channel to key
If base channel with rhncfg packages exists, activation key config deploy add...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Milan Zázrivec
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-06-30 19:31 EDT by Justin Sherrill
Modified: 2009-09-10 16:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:38:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2009-06-30 19:31:01 EDT
So the Channel_queries query channels_with_packages is supposed to list all the child channels with a particular package (the manager layer call is ChannelManager.findChildChannelsWithPackage()).  

The problem is that it doesn't restrict channels to child channels.  Two ways to reproduce (both requiring you to create a base channel with rhncfg* packages in it):

1.  Create base channel 
2.  Push rhncfg* packages to the base channel
3.  Create new activation key (leave base channel to "satellite default")
4.  Check "enable config deploy" and hit submit

Results: the custom base channel will be selected

Second way to reproduce

1.  Create base channel same as above
2.  Create package profile
3.  Create kickstart profile
4.  Within kickstart profile details, set the package  profile to the one created above
5.  Try to re-provision a machine with this profile

Results:  System registration will fail with:

Error Message:
    Token `Kickstart re-activation key for 4u6 dhcp231-208.' has more than one base channel assigned
Error Class Code: 62
Error Class Info: Token contains invalid, obsoleted or insufficient settings
Comment 1 Justin Sherrill 2009-06-30 20:02:07 EDT
0fa36ec 

fixed
Comment 2 Milan Zázrivec 2009-07-07 08:07:17 EDT
Verified, spacewalk-java-0.5.44-27
Comment 3 Steve Salevan 2009-08-21 13:12:33 EDT
RELEASE_PENDING from 8/21 Stage build.
Comment 4 Brandon Perkins 2009-09-10 16:38:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.