Bug 509038 - Random errors of unknown key pressed and released in a terminal
Random errors of unknown key pressed and released in a terminal
Status: CLOSED DUPLICATE of bug 141505
Product: Fedora
Classification: Fedora
Component: Terminal (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
http://www.microsoft.com/hardware/mou...
: HardwareEnablement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 19:41 EDT by steve
Modified: 2010-05-06 23:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-01 11:35:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description steve 2009-06-30 19:41:47 EDT
Description of problem:
I am running fedora 11 and I am getting unknown key pressed and unknown key released in a terminal with X server shut down. 


Version-Release number of selected component (if applicable):
Here is my keyboard model: Microsoft Laser Desktop 4000
Keyboard is model 1045.
Receiver puck is model 1029.

http://www.microsoft.com/hardware/mouseandkeyboard/ProductDetails.aspx?pid=094


How reproducible: 
Every time I am in a terminal with X not running I get the errors. Details of the error are as follows:

I studied the behaviour and it happens when I press any key at random. The
messages appear in a certain interval. For example: I would press the backspace
key for 30 seconds, and every ~ 8 seconds I would get the unknown key pressed.
Then I moved to another key, and the same result. I read where these keyboards
are sending a signal through the receiver puck back to the machine to tell it
that the battery is still good in the keyboard. I have this model plugged in to the ps2 port, but it can be used as a usb device.

An example of my problem is here:

https://bugs.launchpad.net/ubuntu/+source/console-data/+bug/70317

Here is a snippet from the link above, my errors are identical, every few
seconds no matter what key pressed.
atkbd.c: Unknown key released (translated set 2, code 0x81 on isa0060/serio0).
atkbd.c: Use 'setkeycodes e001 <keycode>' to make it known.
atkbd.c: Unknown key pressed (translated set 2, code 0xd9 on isa0060/serio0).
atkbd.c: Use 'setkeycodes e059 <keycode>' to make it known.


Steps to Reproduce:
1. Quit X server
2. Start typing in the terminal window
3. The errors will show immediately
  
Actual results:
Key is pressed and errors are shown every 5 to 8 seconds. The key pressed does not matter. I tried it with a letter, the space bar, backspace key, etc...

Expected results:
There should not be errors when using non multimedia keys.


Additional info:
I am new to fedora and linux in general and I am trying to troubleshoot this
problem. I would like to find a log to show my exact error but the best I can
do for now is use the example from the link above.

Any help is appreciated.

Steve
Comment 1 Kevin Fenzi 2009-07-01 11:35:14 EDT
Looks like this is a long standing bug in kbd somewhere. 
There is already a bug filed on it, so I will mark this as a duplicate of that one and you can continue to provide info there. ;)

*** This bug has been marked as a duplicate of bug 141505 ***

Note You need to log in before you can comment on or make changes to this bug.