Bug 509045 - Hang when booting RHEL5 x86-64 guest
Hang when booting RHEL5 x86-64 guest
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
high Severity high
: rc
: ---
Assigned To: john cooper
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 21:00 EDT by Søren Sandmann Pedersen
Modified: 2014-07-24 23:45 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-18 03:29:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Søren Sandmann Pedersen 2009-06-30 21:00:21 EDT
With 

    kvm-83-82.el5

using this:

    /usr/libexec/qemu-kvm -m 1024 -hda RHEL5.qcow2 -boot c -monitor stdio -qxl 1,ram=32 -spice port=3000,ic=on,sv=on,disable-ticketing
d

I get a hang during boot. The last few lines of /var/log/messages before the hang were:

    Jun 30 20:37:57 dhcp-100-3-19 kernel: kvm: 25365: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
    Jun 30 20:37:57 dhcp-100-3-19 kernel: kvm: 25365: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0xffdb7881
    Jun 30 20:37:57 dhcp-100-3-19 kernel: kvm: 25365: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x530079
    Jun 30 20:40:05 dhcp-100-3-19 syslogd 1.4.1: restart.

It happened twice in a row, so it seems reliably reproducible.
Comment 3 Dor Laor 2009-07-06 12:39:27 EDT
(In reply to comment #0)
> With 
> 
>     kvm-83-82.el5
> 
> using this:
> 
>     /usr/libexec/qemu-kvm -m 1024 -hda RHEL5.qcow2 -boot c -monitor stdio -qxl
> 1,ram=32 -spice port=3000,ic=on,sv=on,disable-ticketing
> d
> 
> I get a hang during boot. The last few lines of /var/log/messages before the
> hang were:
> 
>     Jun 30 20:37:57 dhcp-100-3-19 kernel: kvm: 25365: cpu0 unimplemented
> perfctr wrmsr: 0x186 data 0x130079
>     Jun 30 20:37:57 dhcp-100-3-19 kernel: kvm: 25365: cpu0 unimplemented
> perfctr wrmsr: 0xc1 data 0xffdb7881
>     Jun 30 20:37:57 dhcp-100-3-19 kernel: kvm: 25365: cpu0 unimplemented
> perfctr wrmsr: 0x186 data 0x530079
>     Jun 30 20:40:05 dhcp-100-3-19 syslogd 1.4.1: restart.
> 

Is that a host hang or a guest hand? The above dmesg is the host's.

> It happened twice in a row, so it seems reliably reproducible.  

What happens without spice?
(unrelated: Note that -hda is obsolete, use -drive file=rhel5.qcow,cache=off instead)

In case the guest hangs, can you collect kvm_stat and kvmtrace ouputs?
Comment 4 Søren Sandmann Pedersen 2009-07-07 20:59:03 EDT
This is a host hang and it happens even without spice. Ie., with this command line:

    /usr/libexec/qemu-kvm -m 1024 -hda RHEL5.qcow2 -boot c -monitor stdio 

It only happens when using KVM - ie., if I run the above as non-root, it prints 

    open /dev/kvm: Permission denied

but then it runs, though slowly.
Comment 5 Yaniv Kaul 2009-07-08 00:13:42 EDT
(In reply to comment #4)
> This is a host hang and it happens even without spice. Ie., with this command
> line:
> 
>     /usr/libexec/qemu-kvm -m 1024 -hda RHEL5.qcow2 -boot c -monitor stdio 
> 
> It only happens when using KVM - ie., if I run the above as non-root, it prints 
> 
>     open /dev/kvm: Permission denied
> 
> but then it runs, though slowly.  
It runs without KVM - just QEMU. You need to set the permissions properly.
Comment 6 Dor Laor 2009-07-08 03:56:54 EDT
Can you attach serial or use netconsole to get the messages?
What's the host OS version?
What's the host's cpu?
Comment 7 Søren Sandmann Pedersen 2009-07-14 22:12:38 EDT
Host OS is RHEL 5.4. 

dhcp-100-3-19:~% uname -a
Linux dhcp-100-3-19.bos.redhat.com 2.6.18-155.el5 #1 SMP Fri Jun 19 17:06:31 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

Host CPU is this times four:

dhcp-100-3-19:~% cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
stepping        : 11
cpu MHz         : 2393.982
cache size      : 4096 KB
physical id     : 0
siblings        : 4
core id         : 0
cpu cores       : 4
apicid          : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx est tm2 cx16 xtpr lahf_lm
bogomips        : 4787.96
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:


I don't know how to attach a serial cable or how to use netconsole.
Comment 8 Brian Stein 2009-10-07 14:38:52 EDT
Søren:

Has this been recurring since 7/09 or this issue resolved itself?  AFAIK this issue hasn't shown up during QA, but wanted to confirm it's no longer outstanding.

Please update/close accordingly.  Thanks.
Comment 9 Søren Sandmann Pedersen 2009-10-16 06:01:10 EDT
I don't have the setup to test this anymore. As far as I know it didn't solve itself, but things could have changed in the meantime.

It can't be very common if I am the only one seeing it.
Comment 10 Dor Laor 2009-10-18 03:29:58 EDT
In this case I'll close it as 'worksforme'. Soren and QE, feel free to reopen it if it happens again.

Note You need to log in before you can comment on or make changes to this bug.