This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 509078 - system-config-display unusable (crash)
system-config-display unusable (crash)
Status: CLOSED DUPLICATE of bug 493680
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 05:00 EDT by Sebastian Krämer
Modified: 2009-07-21 13:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 13:54:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sebastian Krämer 2009-07-01 05:00:52 EDT
system-config-display is unusable for me.
When I call it as regular user in terminal, I'm asked for the root password, then it crashes:

$ system-config-display 

(system-config-display:4383): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed

(system-config-display:4383): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 376, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 641, in __init__
    if len(self.xconfig.layout[0].adjacencies) > 1:
IndexError: index out-of-bounds


Version-Release number of selected component (if applicable):
Name       : system-config-display
Arch       : noarch
Version    : 1.1.3
Release    : 2.fc11

I'm using the nvidia kernel modules but I think the problem was the same with nouveau.
Comment 1 Sebastian Krämer 2009-07-01 05:16:51 EDT
Hm, this may well be a duplicate of bug #505972..
Comment 2 Adam Williamson 2009-07-15 17:12:38 EDT
Try removing /etc/X11/xorg.conf (just rename it something else). If it works then, it's probably a dupe of 493680, yeah.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Sebastian Krämer 2009-07-21 06:57:36 EDT
I removed /etc/X11/xorg.conf. system-config-display did start up!
Comment 4 Adam Williamson 2009-07-21 13:54:48 EDT
Then it's probably the same problem. Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 493680 ***

Note You need to log in before you can comment on or make changes to this bug.