Bug 509081 - xfce4-notifyd not conforming to standard (causing crash)
xfce4-notifyd not conforming to standard (causing crash)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xfce4-notifyd (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 05:06 EDT by Sebastian Krämer
Modified: 2010-05-12 06:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-06 18:51:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash log (12.70 KB, text/plain)
2009-07-14 05:07 EDT, Sebastian Krämer
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 587409 None None None Never
Xfce 5602 None None None Never

  None (edit)
Description Sebastian Krämer 2009-07-01 05:06:40 EDT
I'm using banshee from the git repository. Recently (I think with the update to f11/xfce4.6) the application crashes on song change. A bug is filed upstream (to banshee) but the problem lies with xfce4, probably.

Please see the banshee bug report as a reference.

Using the xfce4 desktop as such, notification doesn't cause any problems.
Comment 1 Christoph Wickert 2009-07-01 05:22:35 EDT
There have been some problems with a libnotify API change but this was reverted upstream, so IMHO xfce4-notifyd still is inline with the rest of the Fedora packages.

I guess there is some kind of version mismatch between the different components involved. Do you still see the crash if
- you use notification-daemon?
- you install banshee from the Fedora repos?
- you recompile xfce4-notifyd against all the git stuff you are using?
Comment 2 Christoph Wickert 2009-07-05 09:37:09 EDT
Please try this package:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1454979
Comment 3 Christoph Wickert 2009-07-12 10:35:21 EDT
Ping. Can you please test the package from comment #2?
Comment 4 Sebastian Krämer 2009-07-14 05:07:00 EDT
Created attachment 351565 [details]
crash log

Sorry for the delay. Unfortunately, the issue is not fixed by the updated xfce4-notifyd package.
Comment 5 Christoph Wickert 2009-07-14 06:24:41 EDT
I'm afraid, there is not much I can do, because:
1. I can only support the packages in Fedora and not the ones you build from git snapshots. Can you please test against notify-sharp and banshee from Fedora?
2. xfce4-notifyd follows the spec published at freedesktop.org, the newer (?) version is not available anywhere, so I have no idea what the "version" parameter is supposed to do. I'm in touch with the xdg people, but so far none of them was able to show me the updated spec.
3. I have updated the package you tested to follow notification-deamon, so it *should* work. Can you test with notification-daemon instead? Just install it in addition to xfce4-notifyd.
3. Last but not least: banshee should be more robust and mustn't crash because of the notification. It should simply ignore the "missing" parameter.
Comment 6 Christoph Wickert 2009-07-14 06:27:00 EDT
(In reply to comment #4)
> Unfortunately, the issue is not fixed by the updated
> xfce4-notifyd package.  

BTW: you did logout and in again after upgrading the package, did you?
Comment 7 Christoph Wickert 2009-07-22 19:29:20 EDT
Filed upstream at against xfce4-notifyd:
http://bugzilla.xfce.org/show_bug.cgi?id=5602
Comment 8 Christoph Wickert 2009-08-06 18:51:22 EDT
As you can see, upstream has no intentions of "fixing" this as long as there are no specs he can follow. I on the other hand can only support the packages in Fedora but not you git snapshots.

Closing for now. Feel free to reopen if the circumstances change, e.g. if there is a new version of the notification spec.
Comment 9 Sebastian Krämer 2010-05-12 06:53:50 EDT
Whatever happened in the meantime, the issue is resolved, just so you know. Thanks for your help!

Note You need to log in before you can comment on or make changes to this bug.