Bug 509085 - USB-Soundcard outputs noise, nothing else
USB-Soundcard outputs noise, nothing else
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 05:20 EDT by Jan Willies
Modified: 2009-07-05 08:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-05 08:53:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Willies 2009-07-01 05:20:02 EDT
Description of problem: Whenever I switch the sound from internal soundcard to the usb-card, there's just noise coming out of the speakers. Internal works fine though. I'm using the digital output (SPDIF)


Version-Release number of selected component (if applicable): 0.9.15-14.fc11


How reproducible: always


Steps to Reproduce:
1. attach USB-card
2. play music
3. switch from internal to usb-card
  
Actual results: loud noise 


Expected results: music


Additional info: It worked well with F10. 
The output of alsa-info can be found here: http://www.alsa-project.org/db/?f=947470708990d306b5c804c95cc690226c9fb96e
Also, sometimes there's lots of "ALSA sound/usb/usbaudio.c:354: frame 0 active: -71" in /var/log/messages when attaching the usb-soundcard.
Comment 1 Lennart Poettering 2009-07-01 07:56:09 EDT
what happens if you play audio through aplay?

aplay -f CD -D spdif:xxxx < /dev/urandom

(where xxx is the card index/name)

does that work?
Comment 2 Jan Willies 2009-07-05 08:53:03 EDT
magically works now. there's some initial noise though, while switching, but the card plays after a few secs fine.

thanks for the fast response, please close this ticket

Note You need to log in before you can comment on or make changes to this bug.