Bug 509090 - httpd.workers ends up in seg fault
httpd.workers ends up in seg fault
Status: CLOSED DUPLICATE of bug 502133
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 05:45 EDT by Thorsten Scherf
Modified: 2009-07-04 15:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-04 15:42:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Scherf 2009-07-01 05:45:30 EDT
Description of problem:
I configured my httpd to use httpd.worker. After a restart the sever was not responsive anymore. The log was filled up with the following entries:

[Wed Jul 01 11:38:24 2009] [notice] child pid 15405 exit signal Segmentation fault (11)
...(lots of them)

Switching back to httpd.prefork doesn't help. Server is still unresponsive and produces the above error messages in the log.
 

Version-Release number of selected component (if applicable):
httpd-2.2.11-8.i586

How reproducible:
see above

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Joe Orton 2009-07-01 06:10:11 EDT
What modules do you have installed?  Comment out HTTPD in /etc/sysconfig/httpd, and catch some core dumps:

# echo CoreDumpDirectory /tmp > /etc/httpd/conf.d/coredump.conf
# service httpd restart
...
# gdb /usr/sbin/httpd /tmp/core.xxxxx
...
(gdb) bt
(gdb) bt full
Comment 3 Thorsten Scherf 2009-07-04 15:42:41 EDT

*** This bug has been marked as a duplicate of bug 502133 ***

Note You need to log in before you can comment on or make changes to this bug.