Bug 50910 - When first starting Gnome, it launches unexpected nautilus windows
When first starting Gnome, it launches unexpected nautilus windows
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: nautilus (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-04 14:24 EDT by cbagwell
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 23:17:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cbagwell 2001-08-04 14:24:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.6-3.1 i686)

Description of problem:
I've upgraded from RedHat 7.1 and Roswell.  On initial run of GNOME I had a
problem with the Nautilus select wizard as documented by 50908.

I do not think this problem is related and so I'm writing a seperate bug
report.

When GNOME (using Eazel window manager) finishes loading up, I get my two
terminal windows up that I've saved in past sessions as well as the
standard panel at the bottom of the screen.

I do not get the desktop icons that Midnight Commander used to place. 
Instead I get my CPU pegged as its apparently running Nautilus in the
background.  After around 2 minutes (on my ADM K7 550), I finally get
desktop icons.

I also get around 30 Nautilus Error dialog boxes and 20 Nautilus viewers of
my Home Directory.  If I wait around 3-5 minutes, most of the Error Dialog
boxes go away without me clicking them and even some of the Home Directory
viewers.

Things seem somewhat stable after this intial strange behaviour.

How reproducible:
Always

Steps to Reproduce:
1. Upgrade from 7.1
2. Run GNOME, may need to cancel from initial wizard.
3. Watch screens pop up.
	

Additional info:
Comment 1 Havoc Pennington 2001-08-06 15:49:28 EDT
Did you bang on the "Finish" button in the upgrade wizard?

If so, every time you clicked it you created a new Nautilus.
A GNOME session with a couple dozen Nautilus in it is a Bad Thing. ;-)

gnome-core in rawhide should fix the Finish button to work properly.
Comment 2 Glen Foster 2001-08-06 18:43:25 EDT
We (Red Hat) should try to fix this for the next release.
Comment 3 cbagwell 2001-08-06 23:17:08 EDT
Yes, it turns out the wizard was what caused this.  I had clicked "finish" about
 10 times all together (hit finish a few times, then back, then next, then
finish some more).  After rebooting a few times and getting the wizard again, I
was quickly up to 30 nautilus launches during initial login.

My solution was to delete the .gnome and .nautilus directories and log back in.
 Much more stable now.  I guess the fix for 50908 should fix this for most people.
Comment 4 Havoc Pennington 2001-08-07 00:49:53 EDT
Great, glad it was a known bug. ;-)

Note You need to log in before you can comment on or make changes to this bug.