Bug 509127 - compiler warning in fs/nfsd/nfssvc.c
compiler warning in fs/nfsd/nfssvc.c
Status: CLOSED DUPLICATE of bug 501500
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
low Severity low
: rc
: ---
Assigned To: Jeff Layton
Red Hat Kernel QE team
Depends On:
  Show dependency treegraph
Reported: 2009-07-01 09:38 EDT by Jeff Layton
Modified: 2009-09-24 07:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-09-24 07:27:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch -- fix minor compiler warning (1.23 KB, patch)
2009-07-01 09:38 EDT, Jeff Layton
no flags Details | Diff

  None (edit)
Description Jeff Layton 2009-07-01 09:38:21 EDT
Created attachment 350111 [details]
patch -- fix minor compiler warning

Minor compiler warning:

  CC [M]  fs/nfsd/nfssvc.o
fs/nfsd/nfssvc.c:121: warning: initialization from incompatible pointer type

looks fairly harmless, but should be simple to fix.
Comment 1 Peter Staubach 2009-07-01 09:45:49 EDT
This has existed for a very long and we mostly been waiting for some other
change to nfssrv.c to make this change as well.
Comment 2 Jeff Layton 2009-07-01 10:00:44 EDT
Yep, totally harmless warning, but since I was poking around in there anyway I figured I'd roll a patch for it.
Comment 3 Jeff Layton 2009-09-24 07:27:21 EDT
Folding this patch in with some other fixes in the same area.

*** This bug has been marked as a duplicate of bug 501500 ***

Note You need to log in before you can comment on or make changes to this bug.