Bug 509136 - Software Updates waits forever if pkgs have depsolve issues
Software Updates waits forever if pkgs have depsolve issues
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On: 499968
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 10:05 EDT by Jerry Amundson
Modified: 2009-08-31 16:24 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 16:24:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
window waits until I click Cancel (28.61 KB, image/png)
2009-07-01 10:13 EDT, Jerry Amundson
no flags Details

  None (edit)
Description Jerry Amundson 2009-07-01 10:05:14 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jerry Amundson 2009-07-01 10:13:09 EDT
Created attachment 350121 [details]
window waits until I click Cancel
Comment 2 Jerry Amundson 2009-07-01 10:14:46 EDT
kdebase-workspace-4.2.90-3.fc12.x86_64 

For example using current rawhide, yum exits with:

Packages skipped because of dependency problems:
    evolution-mapi-0.27.3-3.fc12.x86_64 from rawhide
    kdebase-runtime-4.2.95-2.fc12.x86_64 from rawhide
    kdebase-runtime-libs-4.2.95-2.fc12.x86_64 from rawhide
    kdebase-workspace-4.2.95-3.fc12.x86_64 from rawhide
    kdebase-workspace-devel-4.2.95-3.fc12.x86_64 from rawhide
    kdebase-workspace-libs-4.2.95-3.fc12.x86_64 from rawhide
    kdelibs-experimental-4.2.95-1.fc12.x86_64 from rawhide
    kdm-4.2.95-3.fc12.x86_64 from rawhide
    ksysguardd-4.2.95-3.fc12.x86_64 from rawhide
    openchange-0.8.2-3.fc12.x86_64 from rawhide

SU shows the same 10 updates available, but sits waiting forever, or until I click Cancel.
Comment 3 Rex Dieter 2009-07-01 10:35:58 EDT
I assume you're talking about kpackagekit here?
Comment 4 Rex Dieter 2009-07-01 10:37:35 EDT
yeah, it's visiable in systemsettings too -> reassigning
Comment 5 Jerry Amundson 2009-07-01 10:49:23 EDT
(In reply to comment #3)
> I assume you're talking about kpackagekit here?  

Correct.

Clarification - the window must be Closed. "Cancel" is a no-op.
Upon apply, I see these:
enumFromString ( Action ) : converted "unknown" to "UnknownAction" , enum value 1073741824
enumFromString ( Action ) : converted "unknown" to "UnknownAction" , enum value 1073741824
enumFromString ( State ) : converted "" to "UnknownState" , enum value 18
enumFromString ( Action ) : converted "unknown" to "UnknownAction" , enum value 1073741824
enumFromString ( Action ) : converted "unknown" to "UnknownAction" , enum value 1073741824
Comment 6 Steven M. Parrish 2009-07-21 07:51:19 EDT
Will check with upstream concerning this.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Steven M. Parrish 2009-08-26 14:44:31 EDT
New versions of both PackageKit and kpackagekit are now available in Rawhide.  Please update and report if you are still having issues.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.