Bug 509148 - Can't enter password when fingerprint enabled
Can't enter password when fingerprint enabled
Status: CLOSED DUPLICATE of bug 500338
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 10:44 EDT by Kevin R. Page
Modified: 2015-01-14 18:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-10 20:18:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system-auth (931 bytes, text/plain)
2009-07-01 10:44 EDT, Kevin R. Page
no flags Details
/etc/pam.d/gnome-screensaver (485 bytes, text/plain)
2009-07-01 10:45 EDT, Kevin R. Page
no flags Details

  None (edit)
Description Kevin R. Page 2009-07-01 10:44:23 EDT
Created attachment 350125 [details]
system-auth

After upgrade to F11 I installed fprint and associated packages, enabled my fingerprint reader using system-config-authentication, and scanned a fingerprint through the "Account Information..." dialogue.

On login gdm will accept either a password of fingerprint scan.

However, in both cases, when gnome-screensaver locks I cannot unlock using a password - only fingerprint. While the password entry field is active and can be typed into, the "Unlock" button is greyed out (and carriage return therefore activates "Cancel", which is in focus by default).

If the fingerprint scan repeatedly fails (3 times, I think), the "Unlock" button is enabled and password entry works as expected.

Both the fingerprint scan and password entry should be available as soon as the unlock dialog appears so the user has the option to use whichever is convenient at the time.

gnome-screensaver-2.26.1-2.fc11.i586
pam-1.0.91-6.fc11.i586
fprintd-pam-0.1-9.git04fd09cfa.fc11.i586
Comment 1 Kevin R. Page 2009-07-01 10:45:13 EDT
Created attachment 350126 [details]
/etc/pam.d/gnome-screensaver
Comment 2 Dan Winship 2009-12-10 20:18:14 EST

*** This bug has been marked as a duplicate of bug 500338 ***

Note You need to log in before you can comment on or make changes to this bug.