Bug 509157 - Shutdown plugging in empty battery while on AC power
Shutdown plugging in empty battery while on AC power
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 499668 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 11:27 EDT by Kris Buytaert
Modified: 2009-08-21 12:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 08:03:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kris Buytaert 2009-07-01 11:27:16 EDT
Description of problem:


My laptop has 2 batteries, when one of them drains Fedora decides to shutdown the laptop even while on AC power.


Version-Release number of selected component (if applicable):

gnome-power-manager-2.26.2-1.fc11.i586


How reproducible:

3 times in a row

Steps to Reproduce:
1. Plug in Power
2. Take an empty 2nd battery , plug it in 
3. See machine detect low battery power and shutdown
  
Actual results:

Shutdown 

Expected results:
It's on AC power so I expect  
 A.  It not to shut down for safety when the battery goes empty 
 B.  Realize it has a 2nd battery anyhow
 C.  Go on as normal and let the battery charge.



Additional info:

This only happened after my fresh F11 installation .. I never had the problem on F10
Comment 1 Linus Walleij 2009-07-20 16:24:52 EDT
I have a similar problem: when I boot up the machine with a drained
battery, g-p-m will shut it down, even though it is on mains power.

Apparently the current version of g-p-m does only trigger the shut
down rule in accordance with battery level, it doesn't take into account
that a stable AC mains power source is available.

It needs to be amended to not shut down the system when it's on
AC power.
Comment 2 Richard Hughes 2009-08-20 08:03:55 EDT
This should be fixed properly in rawhide. See my blog for more information about how multi-battery laptops are handled.
Comment 3 Richard Hughes 2009-08-20 08:29:23 EDT
*** Bug 499668 has been marked as a duplicate of this bug. ***
Comment 4 Linus Walleij 2009-08-21 12:09:30 EDT
ThX Richard, URL:
http://blogs.gnome.org/hughsie/2009/06/16/gnome-power-manager-and-multiple-
batteries/

Note You need to log in before you can comment on or make changes to this bug.