This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 509209 - preupgrade fails: bootdevpath error and PUerror not defined
preupgrade fails: bootdevpath error and PUerror not defined
Status: CLOSED DUPLICATE of bug 504826
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 14:55 EDT by Laurent Jacquot
Modified: 2014-01-21 18:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-01 15:12:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Laurent Jacquot 2009-07-01 14:55:25 EDT
preupgrade from F10->F11 hangs indefinitely without GUI feedback


preupgrade-1.1.0-1.fc10.noarch on a fully updated F10 system
/boot is on RAID 1

here is the traceback from the console:

treeinfo timestamp: Wed Jun  3 00:01:41 2009
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 238, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 257, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 473, in main_preupgrade
    bootdevpath = bootpath_to_anacondapath(stage2_abs,UUID=True)
  File "/usr/lib/python2.5/site-packages/preupgrade/dev.py", line 86, in bootpath_to_anacondapath
    raise PUError, "/boot is on RAID device %s" % bootdev
NameError: global name 'PUError' is not defined

It seems that there is two bugs here: RAID1 should be supported and PUerror should be defined.
Comment 1 Will Woods 2009-07-01 15:12:32 EDT

*** This bug has been marked as a duplicate of bug 504826 ***

Note You need to log in before you can comment on or make changes to this bug.