Bug 509216 - Pulseaudio skips, uses large amount of cpu time with a2dp output
Pulseaudio skips, uses large amount of cpu time with a2dp output
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 15:20 EDT by Jeremy Fitzhardinge
Modified: 2009-07-30 20:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-30 20:16:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Fitzhardinge 2009-07-01 15:20:50 EDT
Description of problem:
When playing via a2dp bluetooth headphones, the audio output is very choppy and pulseaudio uses ~30-80% of the cpu.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.15-14.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Select a2dp output
2. Start playing music in banshee
3.
  
Actual results:
Music starts, but soon becomes very choppy.  Pulseaudio uses lots of CPU.

Expected results:
Music playing cleanly.

Additional info:
If I start pulseaudio without --no-cpu-limit it dies quickly with:
Jul  1 11:32:39 abulafia pulseaudio[12365]: cpulimit.c: Received request to terminate due to CPU overload.

With --no-cpu-limit, it keeps going.

Playing lower-bitrate audio, like youtube videos, plays fine, with no dropouts.

I'm using Sony DR-BT22A headphones.

I use a bluetooth mouse with no problems, so I think that rules out any low-level bluetooth problem.
Comment 1 Lennart Poettering 2009-07-30 20:16:39 EDT
Some A2DP headsets have issues with flow control. PA in rawhide should deal with those headsets better. Feel free to reopen if the problem is not fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.